Home/Support/Support Forum/cc6 bluetooth and minipcie
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

cc6 bluetooth and minipcie

0 votes
Hi All,

I'm starting to use and develop on CC6SBC Gateway with Yocto Linux.
I would like to use the BLE controller with bluez.
Normally, on other platform, I need to use hciattach with a /dev/ttyxx but the online documentation does not mention the tty i have to use.
Also, do I have to activate the bluetooth by GPIO? And then how I can do that?

I've plugged a 3G board in the MiniPCIE connector. But, the board seems to be not recognized by the linux : I don't see anything about the 3G module in the system trace (dmesg).
Do I have to activate anything? Can you, please, tell me more about this?

Thanks a lot for your support.

Pascal
asked Jan 26, 2015 in Linux by pascal22 New to the Community (1 point)

Please log in or register to answer this question.

4 Answers

0 votes
Did you add bluetooth support with dey-bluetooth package?
Are there any messages on dmesg about bluetooth?

PCI Express is not currently supported. Support for it will be added in DEY 1,7
answered Jan 27, 2015 by LeonidM Veteran of the Digi Community (2,922 points)
serial ports
0 votes
No, I didn't add any package on Yocto for now.
I will add this and come back to you.

Regarding the PCI express : when will you plan the 1.7?

I want to use also the two RS232 serials links and the other on the Xbee connector.
Can you, please, told me the corresponding ttyS ?

Thanks a lot for your support.

Regards,

Pascal
answered Jan 27, 2015 by pascal22 New to the Community (1 point)
0 votes
Bluetooth should be functional out of the box just by doing:

hcitool scan

If that does not work check the HWID with:

hwid read

If you see this:
=> hwid read
Reading HWID: 00000000 00000000
TF (location): 0x00
Variant: 0x00
HW Version: 0
Cert: 0x0
Year: 2000
Month: 00
S/N: 0
=>

your HWID is not programmed. Please let me know and i will provide instructions.

DEY 1.7 should come out within next few month. If you have a support agreement, please open a support case and we will try to provide patches for PCIe and XBEE.
answered Jan 28, 2015 by LeonidM Veteran of the Digi Community (2,922 points)
maybe that :

cd /lib/firmware/ar3k/1020200/
cp PS_ASIC_class_2.pst PS_ASIC.pst

hciattach -t30 /dev/ttymxc1 ath3k
Hi,

The problem is fixed now.

Best regards,

Pascal
0 votes
Is the problem fixed ?

I am in the same situation, with the dey-1.6 modules.

bluetooth stack seems to be correctly started at boottime, but there is no /dev/hciX device created.
answered Oct 9, 2015 by VRoqueta New to the Community (3 points)
The problem is fixed.

The issue appears because the hardware id was not programmed on my CC6.

Stop Uboot at the beginning and type "hwid read".

If the command gives you 0x00, you'll have to program the HwId.
But verify this with digi support.

Best regards,
Pascal
...