Home/Support/Support Forum/Node Identification Indicator frame being sent by XBee-Pro Digimesh

Node Identification Indicator frame being sent by XBee-Pro Digimesh

0 votes

I have a setup where I am talking to a Digimesh node (node A) (8070 firmware all round) via a relay node. I regularly poll the A node to get its RF level. At some stage I also poll the relay node for a while to get its NI, ER, GD and DB. I find that the relay node starts sending Node Identification Indicator frames (95H). This is an example of the frame, starting at the MAC address of the relay "0013 A200 409A B106 FFFE C2FF FE00 13A2 0040 9AB1 0652 454C 2330 3400 FFFE 0101 C105 101E C5".
This is not the standard 95H response, it looks very much like a response to an "ND" request.
This response continues even when I stop polling both nodes. It comes in at a random interval between 10 and 30s. And it seems to go on indefinitely. Have to power the device down to stop the behaviour. Also when I initially power up the two devices the relay does not show this behaviour. I have to start my polling to trigger the behaviour.

As I am going to have a lot of devices in the network, I don't want this behaviour as it creates spurious traffic. In a further test with 5 relays I ended up with usually two doing this behaviour. Seemed to be a different two when I tried power cycling the network.

Is there something I am doing incorrectly or is this a possible bug?
asked Jan 31, 2015 in RF Solutions and XBee by HEN New to the Community (1 point)
edited Jan 31, 2015 by HEN

Please log in or register to answer this question.

4 Answers

0 votes
What are the exact API frames you are sending?

Are you waiting for the response of each before you send the next frame?
answered Feb 2, 2015 by mvut Veteran of the Digi Community (15,323 points)
0 votes
Hi mvut,

thanks for coming in on this. The frames I send out are the Remote At command request and are typically like this "7E00 0F17 AB00 13A2 0040 9AB1 06FF FE02 4744 6D".

I am waiting for a response before sending the next request, although I do have a 2 sec timeout in my software before I send the next request, should a response not arrive. Responses typically take well under 1 second.

The configuration of my relay node is as follows.
<?xml version="1.0" encoding="UTF-8"?> <data> <profile> <description_file>xbp24-dm_8070.xml</description_file> <settings> <setting command="CH">C</setting> <setting command="ID">6F3B</setting> <setting command="MT">1</setting> <setting command="PL">4</setting> <setting command="RR">2</setting> <setting command="CA">0</setting> <setting command="CE">0</setting> <setting command="BH">3</setting> <setting command="NH">3</setting> <setting command="MR">1</setting> <setting command="NN">3</setting> <setting command="DH">0</setting> <setting command="DL">FFFF</setting> <setting command="NI">REL#02</setting> <setting command="NT">20</setting> <setting command="NO">0</setting> <setting command="CI">11</setting> <setting command="EE">0</setting> <setting command="KY"></setting> <setting command="BD">4</setting> <setting command="NB">0</setting> <setting command="RO">FF</setting> <setting command="FT">BE</setting> <setting command="AP">1</setting> <setting command="AO">0</setting> <setting command="D0">1</setting> <setting command="D1">0</setting> <setting command="D2">0</setting> <setting command="D3">0</setting> <setting command="D4">0</setting> <setting command="D5">1</setting> <setting command="D6">1</setting> <setting command="D7">1</setting> <setting command="D8">0</setting> <setting command="D9">0</setting> <setting command="P0">1</setting> <setting command="P1">0</setting> <setting command="P2">0</setting> <setting command="PR">1</setting> <setting command="M0">0</setting> <setting command="M1">0</setting> <setting command="LT">20</setting> <setting command="RP">28</setting> <setting command="IC">0</setting> <setting command="IF">1</setting> <setting command="IR">0</setting> <setting command="SM">0</setting> <setting command="SO">2</setting> <setting command="SN">1</setting> <setting command="SP">C8</setting> <setting command="ST">7D0</setting> <setting command="WH">0</setting> <setting command="CC">2B</setting> <setting command="CT">64</setting> <setting command="GT">3E8</setting> <setting command="DD">50000</setting> </settings> </profile> </data>

I have run a test where I don't ask for the NI, in case that is triggering something unexpected. Result is still the same - just requesting ER, GD and DB from the relay and after a while the relay starts issuing 95H responses of its own accord.
answered Feb 3, 2015 by HEN New to the Community (1 point)
Try just issuing one command at a time instead of two commands at once.
Hi mvut,
            can you please clarify?  I think I am only sending one command at a time.  The example command above is sending "GD" only.  Then I wait for a response to this before sending the next command.
0 votes
What firmware version are you working with?
answered Feb 9, 2015 by mvut Veteran of the Digi Community (15,323 points)
0 votes

Is pin 20 set as Commissioning button? If that is the case and you let it float, interferences may be causing the module to detect a button press and it will trigger the transmission of a Node Identification Indicator frame.

Try grounding the pin and it should stop.

For more information, check Digi's Xbee manual, page 79, that explains the comissioning buttons behavior.
answered Jul 26, 2015 by luiz.lamardo New to the Community (1 point)