Home/Support/Support Forum/Sending IS command in extended sleep

Sending IS command in extended sleep

0 votes
Hi,
I am have 2 xbees (end device + coordinator).
The end device is configured with extended sleep following the example #3 in the User Manual:
SM = 4 (cyclic sleep) or 5 (cyclic sleep, pin wake)
SP = 0x7D0 (2000 decimal, or 20 seconds)
SN = 0x0B (12 decimal)
ST = 0x7D0 (2 second wake time)
SO = 0x06 (enable extended sleep and wake for ST time)
IR = 0x800 (send 1 IO sample after waking)

The End Device is an Analog heat sensor and it is successfully sending out the ADC value at the request IR time.

However I would like to be able to interrupt the sleep time to send a Remote AT request command (i.e 0x17) to get sample back without waiting for the end of a sleep cycle.

The issue I am having is that the end device does not seem to wake up and take a sample. Instead after the expected sleep time is over (4 minutes) I get the sample.

Here is my command:
7E 00 0F 17 01 00 13 A2 00 40 B8 F6 A0 FF FE 02 49 53 09

I would like to disable the periodic sampling and instead control sample request from the coordinator. How can I achieve this while the End Device is in extended sleep?

Thanks for the help!
asked Feb 7, 2015 in ZigBee PRO Featureset (and legacy ZNet 2.5) by amirnathoo New to the Community (1 point)

Please log in or register to answer this question.

1 Answer

0 votes
You can't. You would have to wake the module locally first before you can get it to sample or receive data.
answered Feb 9, 2015 by mvut Veteran of the Digi Community (13,087 points)
...