Home/Support/Support Forum/XBee S6B <---> XBee S6B Ad Hoc Network Not Working

XBee S6B <---> XBee S6B Ad Hoc Network Not Working

0 votes
I am trying to transfer data between two XBee's using an ad-hoc network. My end goal is to have one XBee hooked to a microcontroller transmitting data via UART while a second XBee connected to my computer reads that data.

I use the following settings (from this blog) with no results.

Radio 1 - Ad-Hoc Creator
ATIDTEST
ATIP1
ATAH1
ATMA1
ATDL192.168.1.11
ATMY192.168.1.22
ATMK255.255.0.0

Radio 2 - Ad-Hoc Joiner
ATIDTEST
ATIP1
ATAH0
ATMA1
ATDL192.168.1.22
ATMY192.168.1.11
ATMK255.255.0.0

I have searched through the entire forum trying every possible combination of parameters. I tried both STA mode and SoftAP mode, made sure that my serial connection is sent to transparent, etc. The modules work when I connect them to a wireless router so I know they are not faulty.

What am I missing?

Thank you.
asked Feb 24, 2015 in IEEE 802.11 (Wi-Fi) by dgreenheck New to the Community (1 point)

Please log in or register to answer this question.

2 Answers

+1 vote
Have you tried the steps listed on pages 39 - 40 of the product manual located at http://ftp1.digi.com/support/documentation/90002180_K.pdf ?
answered Feb 25, 2015 by mvut Veteran of the Digi Community (13,036 points)
Yes that was the first thing I tried. One caveat is that I cannot set the channel if the device is IBSS Creator.
I also tried updating the firmware to 2024 from 2021 but now I don't even see options for DL or MY.
You wan to use 2023 or above;  Set the CH command via the ATCH command from the Terminal tab and AT command mode.
I flashed both to 2023 and set the channel of the creator to 1. I followed the manual exactly. Here is what I get:

IBSS Creator
AI - FF
DI - 4
CH - 1
LM - FF

IBSS Joiner
AI - 0
DI - 4
CH - A
LM - FF

Should both XBee's be in STA mode? Do I have to set DO to anything?
0 votes
The CE command should be at the default value of 2. What I would suggest is that you issue the following commands from the terminal tab and then follow the directions on the pages I mentioned before.

+++
ATRE <CR>
ATWR <CR>
ATFR <CR>
ATCN <CR>
answered Feb 26, 2015 by mvut Veteran of the Digi Community (13,036 points)
I did the procedure for each XBee and then followed the manual exactly, but it still did not work.
...