Home/Support/Support Forum/Sleep Current drawn by End Devices

Sleep Current drawn by End Devices

0 votes
HI

I have one coordinator and one end device xbee s2 (2mW modules ) using ZB-Zigbee firmware.

If I configure the end device to send an IO Sample every 20 seconds, the range is awesome 30+ meters easy and study.

The end device was running off an 150mHA Lithium Ion Polymer Battery, I was able to run the end device non stop for 17 days when the coordinator was up and running from a connected power source all the time.

I ran the same test but this time I switch off the coordinator, the end device ran out of battery in 3 days.

My project requires battery powered end devices which will not be connected to a powered coordinator and because of their location they cannot be powered on or off.

The end device will sleep and wake up and try to send an io sample with the below settings.
SM 4
ST 2EE
SP 7DO

My question is why is it draining the battery when the coordinator is power off. How can i minimize the power drain and still have it running on battery for 17 days when my coordinator on powered on?

Appreciate any help!
Thank you.
HG
asked Mar 10, 2015 in RF Solutions and XBee by hgmahanty New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
HG, try looking at the operation of an End Device while in a DIsassociated state within the XBee ZB manual. You should find that it will wake and attempt to assocaite quite freqnently which will draw your current down. That is per the IEEE and ZIgbee protocol.
answered Mar 11, 2015 by mvut Veteran of the Digi Community (15,107 points)
Thanks for your reply Eric. I have been reading the xbee manual and have been trying to figure out if there any other option to minimize channel scanning so that the coordinator does NOT always have to be near the end device or be turned ON all the time.
Appreciate any help, I cannot have the coordinator powered ON and near the sleeping end device but still have to save power on the end device.
Then what I would suggest is getting the Xbee 802.15.4 modules.  They still do cyclic sleep and Pin sleep but do not require the Coordinator to even be in range or on to sleep. Where as the Zigbee Enabled devices you are working with do.
Thanks, I will give it a try for sure. One quick question if you could help.
"To meet ZigBee Alliance XBee®/XBee‐PRO® ZB RF Modules © 2012 Digi International, Inc. 47 requirements, the end device will attempt up to 9 scans per minute for the first 5 minutes, and 3 scans per minute thereafter. Note: The XBee ZB end device will not enter sleep until it has completed scanning all SC channels for a valid network."

I got the above paragraph from the xbee manual, however the end device does not seem to be following this, it scans every time it wakes up, am i missing a setting?
 
Also is there is anyway i can force the coordinator and the end device to just one channel?

Thank you in advance!
I think you are going to need to use a spectrum analizer to verify if it is scanning that often and how many channels it uses.  As for how to configure a Zigbee device to only use the desired channels, that is simply done by setting the SC value to the desired channel.  Just make sure you set the coordinator to use the same channel otherwise they will not associate.
Thanks , I will give it a try.
...