Home/Support/Support Forum/L2TP PPP problems to Windows 2008Rs RRAS
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

L2TP PPP problems to Windows 2008Rs RRAS

0 votes
Hello:

I am trying to get a L2TP link up between a WR44 and Windows 2008R2 following AN26. In windows I have configured RRAS authentication to use ONLY MS-CHAP-V2 and NOT use EAP, hence bypassing NPS.
In Windwos firewall you can see the IPSec come up for quick mode and main mode and the PPP negotiation starts, but it fails every time, here is the event viewer form the Digi:
16:41:26, 25 Mar 2015,L2TP Call 0 down
16:41:26, 25 Mar 2015,PPP 2 down
16:41:26, 25 Mar 2015,PPP 2 Start AUTHENTICATE
16:41:25, 25 Mar 2015,PPP 2 Start LCP
16:41:24, 25 Mar 2015,PPP 2 Start AUTHENTICATE
16:41:22, 25 Mar 2015,PPP 2 Start LCP
16:41:22, 25 Mar 2015,PPP 2 Start
16:41:22, 25 Mar 2015,L2TP Call 0 up

Here is the wireshark dump for the same thing:
"No.","Time","Source","Destination","Protocol","Length","Info"
"1","0.000000","N/A","N/A","PPP LCP","27","Configuration Request"
"2","0.070000","N/A","N/A","PPP LCP","57","Configuration Request"
"3","0.070000","N/A","N/A","PPP LCP","35","Configuration Reject"
"4","0.070000","N/A","N/A","PPP LCP","27","Configuration Ack"
"5","0.090000","N/A","N/A","PPP LCP","30","Configuration Request"
"6","0.090000","N/A","N/A","PPP LCP","11","Configuration Nak"
"7","0.120000","N/A","N/A","PPP LCP","27","Configuration Request"
"8","0.120000","N/A","N/A","PPP LCP","27","Configuration Ack"
"9","0.120000","N/A","N/A","PPP CHAP","23","Challenge (NAME='', VALUE=0xf747c2c1ca9a5b45ce2c4e06be902f96)"
"10","0.140000","N/A","N/A","PPP CHAP","30","Challenge (NAME='NEPTUNE', VALUE=0x5bf992059438cef58a5e99b88d0ccdca)"
"11","0.140000","N/A","N/A","PPP CHAP","63","Response (NAME='remote1', VALUE=0xf747c2c1ca9a5b45ce2c4e06be902f960000000000000000...)"
"12","0.170000","N/A","N/A","PPP CHAP","48","Success (MESSAGE='S=E4DEAB4FB6E30EB0C7F0AE8126DBE41966F3D66D')"
"13","0.170000","N/A","N/A","PPP LCP","57","Configuration Request"
"14","0.170000","N/A","N/A","PPP LCP","27","Configuration Request"
"15","0.170000","N/A","N/A","PPP LCP","35","Configuration Reject"
"16","0.210000","N/A","N/A","PPP LCP","13","Configuration Reject"
"17","0.210000","N/A","N/A","PPP LCP","22","Configuration Request"
"18","0.210000","N/A","N/A","PPP LCP","30","Configuration Request"
"19","0.210000","N/A","N/A","PPP LCP","11","Configuration Nak"
"20","0.240000","N/A","N/A","PPP LCP","22","Configuration Ack"
"21","0.240000","N/A","N/A","PPP LCP","27","Configuration Request"
"22","0.240000","N/A","N/A","PPP LCP","27","Configuration Ack"
"23","0.240000","N/A","N/A","PPP LCP","8","Termination Request"
"24","0.280000","N/A","N/A","PPP CHAP","30","Challenge (NAME='NEPTUNE', VALUE=0xbf951c2e4e9d19a03f8d211dfca59e38)"
"25","0.280000","N/A","N/A","PPP LCP","8","Termination Ack"

The MS ppp.log, which is too big to post here, indicates that teh WR44 sent the termination request....
Why?

Any ideas?

Cheers,
John
asked Mar 25, 2015 in Digi TransPort by jserink New to the Community (44 points)

Please log in or register to answer this question.

2 Answers

0 votes
An update to the above.
I can connect to that RRAS server with a Windows7 Pro box using L2TP.

cheers,
john
answered Mar 25, 2015 by jserink New to the Community (44 points)
0 votes
Solved!
You need to remember you're working with windoze......
Remove RRAS,
Reboot,
Change socks,
Install RRAS,
Reboot,
Keep socks on,
Ok, now it works........

if you make ANY change, including your socks, stop, start the service.

It is worth considering WHY Windoze OF ANY VERSION is NOT used to run nuclear power stations.

nuf said.

Cheers,
john
answered Apr 13, 2015 by jserink New to the Community (44 points)
...