Home/Support/Support Forum/xbee joining in XBee S2C module with firmware version 0x4041

xbee joining in XBee S2C module with firmware version 0x4041

0 votes
Hi All,

I have three X4 gateways with 0x21b1 firmware version running as a coordinators and I have some devices i.e. XBee S2C module with firmware version 0x4041.

One gateway is on channel 0x11 and other two gateways on 0x17 channel with different PAN ID's.

My XBee S2C module first joined the channel 0x11 as it starts scanning from first channel, after some time I forced the device to leave the network and it joined the channel 0x17(1 gateway out of 2). When I did the cycling for leaving the current network, device is joining only one gateway of the channel 0x17. It never joined the other gateway.

So, I would like to know what parameter determines joining of router in S2C modules. Is it depends on the signal strength or Extended PAN ID ?

Please reply.
asked Apr 13, 2015 in XBee Programmable Development by Shiva New to the Community (2 points)
edited Apr 13, 2015 by Shiva

Please log in or register to answer this question.

2 Answers

0 votes
Look in your XBee manual for the DO - Device Options AT register. The XBee can be configured to either join the highest RSSI (signal strength) gateway or the first gateway detected.

You can force the XBee to join a desired network by setting SC (Scan Channels) or ID (Extended PAN ID) to match.
answered Apr 13, 2015 by jlovinger Veteran of the Digi Community (421 points)
0 votes
It is determined by both. More so the extended PAN ID.
answered Apr 21, 2015 by mvut Veteran of the Digi Community (15,223 points)
...