Home/Support/Support Forum/Did i brick an XBee S2 module?

Did i brick an XBee S2 module?

+1 vote
After flashing XBee S2 module to Coordinator API i couldn't reflash it or make something else.

New XCTU doesn't connect to that module. I tried to use XCTU's recovery utility, but still no activity from the module.

If i use old X-CTU with 115200 baud and API enabled , then it will show this

and will be some symbols at the terminal like this

I tried to restore it followed that manual. It didn't help me.

Did i brick the Xbee module?

p.s. i flashed the XBee module through DFRobot Xbee USB adapter (FTDI ready). Is it normal to load firmware through that device?
asked Apr 29, 2015 in IEEE 802.15.4 by wonderg New to the Community (2 points)
edited Apr 29, 2015 by wonderg

Please log in or register to answer this question.

1 Answer

+1 vote
If that board has the DTR, RTS, DI and DO connected, then you can flash firmware with that board. Note that most 3rd party board do not connect DTR and RTS.

If you use the Terminal tab of XCTU and use the Show Hex option, what do you see?
answered Apr 30, 2015 by mvut Veteran of the Digi Community (11,298 points)
...