Home/Support/Support Forum/XCTU for Linux ?
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

XCTU for Linux ?

0 votes

Is it possible to use XCTU in Linux? (Ubuntu 14.04 or 15.04 (64 bits))

asked May 1, 2015 in Feedback/Wish List by gpio New to the Community (22 points)

Please log in or register to answer this question.

4 Answers

+2 votes
Best answer
Turns out that the next generation version also works under wine, except that you have to add some registry values to make it actually detect your serial ports.

Credits for figuring this out go to Doug Brown, who has documented the needed steps on his blog: http://www.downtowndougbrown.com/2013/03/getting-x-ctu-in-wine-to-detect-your-serial-ports/ (his post is about getting the legacy version to autodetect serial ports, but I've just tested this and it works with the next generation version too).
answered May 4, 2015 by matthijs Community Contributor (78 points)
selected May 4, 2015 by gpio
+1 vote
I've read that the legacy version works under wine, I haven't tried that yet.

I've tried the latest ng version in wine, which installs and runs, but fails to detect the serial ports. Since the ng version is a java program, I've tried running it through my native java version, but that didn't work out either (it kept looking for classes with "win32" in their name). Perhaps either of these approaches could be made to work, but not out-of-the box at least.

To flash firmware, at least to S2 (ZB) devices, there is the xbee-comm tool (haven't tried that yet either).

To configure a module running in AT mode, you can of course use a serial console program like minicom or screen.
answered May 1, 2015 by matthijs Community Contributor (78 points)
0 votes
Thank you,

sudo minicom /dev/ttyUSB 9600

not work to me.

sudo screen /dev/ttyUSB 9600

receives the OK, on the screen shows only the K and then no longer responds.

I do not find the firmware to XBP08


I look for the firmware for API Mode of XBee Pro 868

UPDATE: screen work to me now.
answered May 1, 2015 by gpio New to the Community (22 points)
edited May 2, 2015 by gpio
0 votes

Thanks you for the new XCTU version to Linux. Works fine to me.

Best regards
answered Jun 28, 2015 by gpio New to the Community (22 points)
Using linux serial port not called ttyUSB?