Home/Support/Support Forum/I am getting only 160m range with XBEE PRO S2B

I am getting only 160m range with XBEE PRO S2B

0 votes
I am using XBEE PRO S2B module series.I am not able to get range 1.2 Km as mentioned in datasheet. I am getting only 160m with no data loss at line of sight. My instrument is Battery powered(3V,5000mAH). I have also tested it in boost mode at power level 4, still it failed to work. Can there be any environmental interference? Kindly suggest best possible way to improve range.
Thank You
asked May 5, 2015 in IEEE 802.11 (Wi-Fi) by poonam patil New to the Community (1 point)

Please log in or register to answer this question.

2 Answers

0 votes
What is the full part number of the module you are using on both sides?

What is the height of the antennas you are using? Are there any obstructions between them?

What addressing functions are you using on the two modules?
answered May 5, 2015 by mvut Veteran of the Digi Community (11,966 points)
part number : XBP24BZ7UIT-004-revF0013A20040C8496F

antenna height : 100mm with no obstructions in between
 
I am sending data from End device to Coordinator.
Coordinator is always USB powered and end device is battery powered
End device is used in pin hibernate mode, it transmits data after every  5 Sec. &  goes to sleep mode.
I have given a delay of 30mSec before sleep and after transmission of data frame in API mode , for proper operation.
I am not sending any data from co-ordinator to end device.
 
Addressing for co-ordinator
DH - 0
DL - FFFF

Addressing for End device.
DH - 0
DL - 0

64-bit dest. address: 00 00 00 00 00 00 00 00
16-bit dest. address: FF FF
I would suggest reading over http://knowledge.digi.com/articles/Knowledge_Base_Article/Maximizing-range. You will find that 4' above obstructions or the earth will not get you vary far,  You will simply need to get more antenna height in order to go farther.
0 votes
Hey Poonam Patil,

I am facing the exact same range problem with my XBEE PRO s2b.... perfect signal and coms within 100m... but as soon as I am moving further away, I instantly loose comms to the end devices...
Have you found a solution for our problem yet?

@DIGI Team: please advice... we need your help.

Thank you
answered Nov 13, 2019 by James-Drones New to the Community (1 point)
...