Home/Support/Support Forum/Set Admin User Login for Web Interface (No "Users" Section)

Set Admin User Login for Web Interface (No "Users" Section)

0 votes
I have the following gateway device:
Code:
Model: XBee Gateway Wi-Fi Product ID: 0x8032 Firmware Version: 3.2.7.10 xbgw release gw-3.2.7.10 08/04/2014 13:13:28 CDT

According to the old X2e manual there should be a "Users" section in the web interface that allows the setting of the Admin password. In this particular model I cannot find anywhere where I can assign an admin password and instead the web interface is constantly open and accessible. Is there any way to set the admin password on the new XBee Gateways?

If not, then is there a way to enable the web access via ssh (at least that's password protected)? I could then simply disable web access and then just enable it from ssh when needed.

Thanks!
asked May 26, 2015 in Linux-based Gateways by jhockman New to the Community (3 points)

Please log in or register to answer this question.

2 Answers

0 votes
You are correct in that there is no user menu in the web interface. Can you point out where this is documented? This should be raised as a failure with Digi.

Meanwhile, you can change the default password from the CLI/SSH using the passwd command.
answered May 27, 2015 by userid0 Veteran of the Digi Community (2,156 points)
0 votes
## python script
import rci_nonblocking as rci
## change enable on/off
request_string_get_service="""
<rci_request vsesion ="1.1">
<set_setting>
<http>
<enable>on</enable>
<port>80</port>
</http>
</set_setting>
</rci_request>
"""
print rci.process_request(request_string_get_service)
answered May 29, 2015 by maxhawkdown New to the Community (6 points)
...