Home/Support/Support Forum/Need help configuring PortServer II access to Linux console on i.MX53
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Need help configuring PortServer II access to Linux console on i.MX53

0 votes
I am using a PortServer ll (fairly certain "without RealPort")

I am trying to connect to console of i.MX53 board running Ubuntu Linux. I have verified the board powers, runs U-boot then boots Linux. All the console traffic appears via a USB-serial dongle connected to host (OS X).

Yet, I am unable to connect with 'telnet 192.168.1.88 2001` to the i.MX53 console port.

The cat5 is connected to Port 1 on front of PortServer and to an official Digi TS Console Adapter part # (1P) 63000086-01 B. I also added a male-male gender changer to accommodate the i.MX53.

I performed part one of the diagnostics (described in Testing and Troubleshooting a PortServer guide); and it worked as expected.

I made a loopback connector according to the Digi documentation. I am successfully able to telnet to IP address; then `connect 8` to port 8 which is configured for loopback operation. It works.

Please offer a suggestion for a fix or recommend troubleshooting tasks. That would be super helpful! :)

Here are some general configs and settings for port 1:
Code:
#> cpconf term # PortServerII Version 3.1.13 Nov 1 2006 # ROM version 106, Amount of RAM: 4 Megs set tcp realport=771 rto_max=240 sockets=2000 keepalive_idle=02.00.00 set tcp probe_count=10 probe_interval=75 set radius authentication=1645 accounting=1646 #> set ports ra=1 serial# termtype dev sess uid edelay auto bin group dport dest 1 vt100 prn 4 0 1 off off 0 0 0.0.0.0 #> set line ra=1 serial# baud csize parity stopb break error inpck istrip onlcr otab 1 115200 8 N 1 ignore null off off off off #> set flow ra=1 serial# ixon aixon ixoff ixany itoss altpin rts dtr cts dcd dsr ri 1 on off on off off on on off on off off off #> set config PortServerII Version 3.1.13 Nov 1 2006 Copyright 1990-2001 Digi International. All Rights Reserved. myname : domain : ip : 192.168.1.88 submask : 255.255.255.0 gateway (LAN) : 192.168.1.1 nameserv : 0.0.0.0 boothost : 192.168.0.56 bootfile : 40001260_af.bin ether : 00:40:9d:24:1d:37 icmp redirects : ignore bootpserver : bootpgenericfile : bootp : no tftpboot : no


Many thanks to everyone who took the time to read!

It turns out the port is configured properly. I tried two other embedded Linux boards from different manufacturers (which did not require the gender changer). Those work fine.

I still do not know why the i.MX53 does not operate with this port.

As unlikely as it may be problem; the gender changer is the only other difference in datapath.

Artie :)
asked Jun 14, 2015 in Linux by aziff New to the Community (1 point)
edited Jun 15, 2015 by aziff

Please log in or register to answer this question.

2 Answers

0 votes
It appears the port is configured to use both software and hardware flow control. I recommend turning off hardware flow control in the event the cable is not wired for it as this would prevent communication on the port.

set flow cts=off rts=off

If this does not work, please post the pin-outs for your cable.
answered Jun 15, 2015 by userid0 Veteran of the Digi Community (2,158 points)
How does this forum supposed to operate?
0 votes
Thank you quite very much for your response.
I hope that I am answering the question correctly.

The pinout diagram for connector 76000697 is:
http://ftp1.digi.com/support/cabling/90000606_a.pdf

Are there any actions or tests which may yield additional information?

thank you!
aziff
Code:
Port TD RD RTS CTS DSR DCD DTR RI OFC IFC 1 off off off off off off off off off off
answered Jul 23, 2015 by aziff New to the Community (1 point)
edited Jul 23, 2015 by michaelt
...