Home/Support/Support Forum/User block read and write not working for RCM4300 using Dynamic C 10.72
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

User block read and write not working for RCM4300 using Dynamic C 10.72

0 votes
When I tried to read saved text files from 'User Block' in debug mode it worked very well but after trying same thing in run mode I am not able to access my Rabbit card on network. Is there any patch for this like one given for Dynamic C 10.21/23. I am using Dynamic C 10.72. Please give me solution for the same.
asked Jul 4, 2015 in Rabbit Software by rahul24 New to the Community (0 points)
recategorized Jul 6, 2015 by LeonidM

Please log in or register to answer this question.

1 Answer

0 votes
Hello according to Digi's website this patch is already implemented and is part of Dynamic C later releases.
If you still see that there is a problem after installing Dynamic C 10.72 and all patches I would contact Rabbit tech support.

See website content below:
Dynamic C 10.21/10.23 User block patch for RCM4300/RCM4310 in Run Mode
The patch provides a new STDBIOS.C file to correct a bug that affected reads/writes from/to the user block when operating the RCM4300/RCM4310 in the Run Mode. The patch replaces the STDBIOS.C file in the Dynamic C v. 10.21/10.23 releases. This patch already exists in later Dynamic C releases.
answered Jul 9, 2015 by Campbell Veteran of the Digi Community (879 points)
Thanks for your replay.
I have tried this so many times but getting the same response from my Rabbit Card.