Home/Support/Support Forum/How do I fix XBee ZB losing connection and not reconnecting?

How do I fix XBee ZB losing connection and not reconnecting?

0 votes
I have a very simple network of two XBees. One Coordinator and one sleeping end device. I have the same setup installed in a few locations.

After several weeks, I am finding that the connection is lost and they don't seem to reconnect. Power cycling the coordinator doesn't seem to lead to them reconnecting. They only reconnect when you reset the end device, but that is hard to do. This seems to remain true even after waiting for several days.

Any advice on how to diagnose the problem, or an actual solution would be greatly appreciated. Below are my end device settings:
Code:
<?xml version="1.0" encoding="UTF-8"?> <data> <profile> <description_file>XB24-ZB_28A7.xml</description_file> <settings> <setting command="ID">1111</setting> <setting command="SC">FFFF</setting> <setting command="SD">3</setting> <setting command="ZS">0</setting> <setting command="NJ">FF</setting> <setting command="JN">0</setting> <setting command="DH">0</setting> <setting command="DL">0</setting> <setting command="NI">0x20</setting> <setting command="NH">30</setting> <setting command="BH">0</setting> <setting command="DD">30000</setting> <setting command="NT">3C</setting> <setting command="NO">0</setting> <setting command="CR">3</setting> <setting command="SE">E8</setting> <setting command="DE">E8</setting> <setting command="CI">11</setting> <setting command="PL">4</setting> <setting command="PM">1</setting> <setting command="EE">0</setting> <setting command="EO">0</setting> <setting command="KY"></setting> <setting command="BD">6</setting> <setting command="NB">0</setting> <setting command="SB">0</setting> <setting command="RO">3</setting> <setting command="D7">1</setting> <setting command="D6">1</setting> <setting command="CT">64</setting> <setting command="GT">3E8</setting> <setting command="CC">2B</setting> <setting command="SM">5</setting> <setting command="ST">1388</setting> <setting command="SP">40</setting> <setting command="SN">1</setting> <setting command="SO">0</setting> <setting command="PO">0</setting> <setting command="D0">1</setting> <setting command="D1">0</setting> <setting command="D2">4</setting> <setting command="D3">0</setting> <setting command="D4">0</setting> <setting command="D5">1</setting> <setting command="P0">1</setting> <setting command="P1">0</setting> <setting command="P2">0</setting> <setting command="PR">1FFF</setting> <setting command="LT">0</setting> <setting command="RP">28</setting> <setting command="DO">1</setting> <setting command="IR">0</setting> <setting command="IC">0</setting> <setting command="V+">0</setting> </settings> </profile> </data>
asked Jul 9, 2015 in RF Solutions and XBee by warehousejim New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
First, set your SP and ST time on the coordinator to match the SP and ST on your end device. Next make sure you are using the current firmware version for both devices and that should take care of it.
answered Sep 3, 2015 by mvut Veteran of the Digi Community (13,094 points)
...