Home/Support/Support Forum/GCC latest version on digi connect ME 9210?
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

GCC latest version on digi connect ME 9210?

0 votes
My device is Digi Connect 9210 and I want to use the latest version of GCC.

The latest Digi Embedded Linux provided uses GCC 4.3, but I want to use 5.1.

Would it work if I just build the cross-compiler on my own (Target: arm-linux-uclibc), or will I have to do extra work? I'm not familiar with low-level compilers / architecture.

By the way, not sure if it matters but I'll be running under the latest Digi ESP ( 5.9.8 ) and the Kubuntu 12.04 for DigiEL.
asked Jul 13, 2015 in Linux by Emeric New to the Community (0 points)
edited Jul 13, 2015 by Emeric

Please log in or register to answer this question.

1 Answer

0 votes
DEL 5.9.8 is for Freescale platforms. The latest DEL that supports ME9210 is DEL 5.7.2

And you'd probably have to build entire toolchain not just a crosscompiler and also will have to rebuild all the libraries (busybox, uClinux, etc) on the target. This is pretty complicated and probably not worse the effort.
answered Jul 13, 2015 by LeonidM Veteran of the Digi Community (3,028 points)
...