Home/Support/Support Forum/xbee s2b in pin sleep using more current than expected

xbee s2b in pin sleep using more current than expected

0 votes
I've got an S2B I am putting in and out of pin sleep hibernate every 10 seconds (effected by an arduino).

My power consumption is as follows:

with xbee plugged into board
- sleep -- 40mA
- awake -- 115-120mA

with xbee unplugged from board (running same code)
- sleep -- 21mA
- awake -- 32mA

subtracting these, I am calculating that the xbee is using
- sleep -- 19mA
- awake -- 83mA

running a similar test with a xbee in router mode, I get the following readings
- sleep (arduino, not xbee) -- 67mA
- awake (arduino, not xbee) -- 78mA

My expectation is the xbee should draw < 1mA when asleep and should only draw ~ 80mA when awake when transmitting / receiving.

Is this a correct assumption? If so, how can I make this happen?

Heath
asked Jul 17, 2015 in ZNet 2.5 by hwestbrook New to the Community (5 points)

Please log in or register to answer this question.

1 Answer

0 votes
 
Best answer
Hi Heath,

I had the same problem a while back.

make sure that you are not doubling up on pull-ups.

for all connections between Arduino and Bee I turn off the internal pull-ups in the Arduino and let the Bee do the work.

current draw in pin sleep mode should be around 1 uA.

cheers
alanp
answered Jul 26, 2015 by alanp New to the Community (33 points)
selected Jul 27, 2015 by hwestbrook
Sorry, flagged this on accident.

Your answer is correct. I had the pin connected to CTS set as output, so they were "fighting" as soon as it was set to input, it was no longer sinking so much current and I am closer to 1uA.
Glad to hear it. I have boards with ATmega328p @ 4Mhz and Xbee  drawing just over 5uA in sleep mode. just takes a bit of tuning of the 328p.
...