Home/Support/Support Forum/XB24-Z7 endpoint only transmits after coordinator sends data.

XB24-Z7 endpoint only transmits after coordinator sends data.

0 votes
Hi,

I set two xb24-z7uit-004 devices to factory defaults, set a PAN ID to 1000 on both, and set one to be an AT endpoint and the other an AT coordinator. Each has the other's serial number as the destination address.

Typing into the endpoint does not change the blinking On LED for the endpoint. No data is sent or buffered.

Typing into the coordinator changes the On LED on the endpoint, and sends that data to the endpoint, where it shows up on the terminal.

At that point, I can type into the endpoint and data will go to the coordinator and display on the coordinator terminal. If I let it sit idle for 10 seconds, I can no longer send from the endpoint. Typing anything on the coordinator end allows me to send again.

It seems like it should work the same both ways. Any ideas would be appreciated.

Dave
asked Aug 10, 2015 in ZigBee PRO Featureset (and legacy ZNet 2.5) by dallmon New to the Community (3 points)
edited Aug 9, 2015 by dallmon

Please log in or register to answer this question.

1 Answer

+1 vote
 
Best answer
End devices sleep so you must use hardware flow control on the End device to keep from loosing the data while the End device sleeps. If you want to talk to them without using flow control, set the end device as a router.
answered Aug 10, 2015 by mvut Veteran of the Digi Community (13,094 points)
selected Aug 10, 2015 by dallmon
...