Home/Support/Support Forum/3 Xbee s1 with 2 Arduinos Communication Star Topology

3 Xbee s1 with 2 Arduinos Communication Star Topology

0 votes
i am using 3 XBee s1 802.15.4 and i have 2 arduinos (uno,mega)As you can see i am trying to build a star topology network in AT mode.I have one master and 2 slaves When i try to make peer to peer communication it works well but whenever i try to put the 3rd xbee i can not provide the communication
Let me tell you what i did ;
----to put the same PAN ID for each xbee in network
----to set master as coordinator
----to set the baud rate same for all(9600)
----to set NODE ID of slaves as 1 and 2
----to set RO Packetization Timeout 0
----to set D7 disabled
with those settings i can chat on XCT-U with all XBees without programme arduinos but when i try to put smthng to the arduino with xbee(slave) it doesnt work For instance whenever i try to begin the serial connection with arduino ( Serial.begin(9600); it destroys everything

i watched hundreds of tutorials and i couldnt make it
asked Aug 18, 2015 in IEEE 802.15.4 by celalcan New to the Community (0 points)
edited Aug 18, 2015 by celalcan

Please log in or register to answer this question.

1 Answer

0 votes
Most of your Arduino samples codes and tutorials are using the XBee ZB product and API mode. You need to either modify that code to use the API of the 802.15.4 modules or modify the code to just send over a COM port just like a cable is connected.
answered Aug 24, 2015 by mvut Veteran of the Digi Community (11,302 points)
...