Home/Support/Support Forum/XBee Pro 868 (AT-Mode) stops transmitting after some while, low baudrate

XBee Pro 868 (AT-Mode) stops transmitting after some while, low baudrate

0 votes
Hello everyone,
I have a problem with a project of mine.
I am using 2 XBee Pro 868 in Transparentmode, one Connected to an IBoard, the other one to a Arduino FIO clone. The Fio is part of a handheld remote control, the IBoard is receiving and sending received data an Ethernet.

The Problem is, that after some time/sent bytes, the XBee on the FIO which is the transmitting one stops sending data. After some research on google i found that this might be connected to a too high Baudrate, so i tried different baudrates, but it still stopped sending. I Also tested this with a simple Serial.sSend Arduino Programm to make sure it is not a bug in my Control Programm.

The Arduino Code:
Code:
void setup() { Serial.beginn(9600); } void loop() { Serial.print("hello "); delay(200; }

I tested with the following baudrates:
2400
4800
9600
19200
56700

The XBees config is:
Code:
<?xml version="1.0" encoding="UTF-8"?> <data> <profile> <description_file>XBP08-DP_1061.xml</description_file> <settings> <setting command="ID">1234</setting> <setting command="RR">A</setting> <setting command="MT">3</setting> <setting command="CE">0</setting> <setting command="PL">2</setting> <setting command="DH">0</setting> <setting command="DL">FFFF</setting> <setting command="NI">0x20</setting> <setting command="NT">82</setting> <setting command="NO">0</setting> <setting command="DD">60000</setting> <setting command="EE">0</setting> <setting command="KY"></setting> <setting command="BD">6</setting> <setting command="NB">0</setting> <setting command="SB">0</setting> <setting command="RO">3</setting> <setting command="D7">1</setting> <setting command="D6">0</setting> <setting command="FT">13F</setting> <setting command="AP">0</setting> <setting command="AO">0</setting> <setting command="D0">1</setting> <setting command="D1">0</setting> <setting command="D2">0</setting> <setting command="D3">0</setting> <setting command="D4">0</setting> <setting command="D5">1</setting> <setting command="D8">0</setting> <setting command="D9">1</setting> <setting command="P0">1</setting> <setting command="P1">0</setting> <setting command="P2">0</setting> <setting command="P3">1</setting> <setting command="M0">0</setting> <setting command="M1">0</setting> <setting command="LT">0</setting> <setting command="RP">28</setting> <setting command="PR">7F7F</setting> <setting command="IC">0</setting> <setting command="IR">0</setting> <setting command="IF">1</setting> <setting command="CT">64</setting> <setting command="GT">3E8</setting> <setting command="CC">2B</setting> <setting command="WH">0</setting> <setting command="SO">0</setting> <setting command="SM">0</setting> <setting command="SN">1</setting> <setting command="SP">C8</setting> <setting command="ST">7D0</setting> </settings> </profile> </data>

I also tried changing the UART Treshold (Setting it to 16F) and Packetization Timeout (setting it to 0) butthis didnt fix it either.

Can Anybody help me with this, or is there someone who could think of something causing this?


Thanks in Advance
Lukas
asked Aug 26, 2015 in RF Solutions and XBee by naegionn New to the Community (1 point)

Please log in or register to answer this question.

1 Answer

0 votes
 
Best answer
This is a not a Code issue but a transmit duty cycle limit issue that is documented in the manual. That is to say, the XBee PRO 868 is limited to transmitting only 10% of the time. The rest of the time the module must be listening.
answered Aug 31, 2015 by mvut Veteran of the Digi Community (13,333 points)
selected Aug 31, 2015 by naegionn
...