Home/Support/Support Forum/S2c DOUT and RPI

S2c DOUT and RPI

0 votes

I have a device based on Raspberry pI model 2 connected serially to an xbee pro in API coordinator mode.

Up until now I have been using S2Bs with no problems. 30+ units built.

Have tried moving to S2C TH and the unit fails to work.
On the CRO the Dout remains HI. Din working correctly.

Have tried multiple RPIs, multiple interface boards, all with same result.
Plug S2B in and all works again.
I can pull line down with 10K resistor thus line is not being held up.
It appears that Dout is just not talking.

S2c works fine talking to AVR and on XBIB

what changes have been made between S2B and S2C TH that might cause this? (have tried pullup/pulldown to no avail.)


asked Nov 19, 2015 in ZigBee PRO Featureset (and legacy ZNet 2.5) by alanp New to the Community (33 points)

Please log in or register to answer this question.

1 Answer

0 votes
Check the P3 command and make sure that it is set to Data Out. Also make sure that you are not controlling any of the SPI port lines.
answered Nov 19, 2015 by mvut Veteran of the Digi Community (15,409 points)