Home/Support/Support Forum/Get response from remote Xbee END API+TOSR-0X (relay module)

Get response from remote Xbee END API+TOSR-0X (relay module)

0 votes
Please point me in right direction, I'm xbee-noob and missing something trivial :)

I have the following setup:

Name=COORD1 - ZigBee Coordinator API / 21A7 / XB24-ZB attached now to server through Xbee USB adapter

Name=END1 - ZigBee end device API / 29A7 / XB24-ZB sitting into TOSR-0X (http://goo.gl/WfVRlk)

TOSR-0X has an set of ASCII-commands (http://goo.gl/fntfZI) to turn on / off relays. I'm doing this successfully by sending 0x10 commands from COORD1 to END1.

There is a ASCII-command to get a relay state and I'm could not figure out how to receive this data back from END1.

What is a correct way to force END1 to send it's serial input to COORD1 in API mode? It seems to be a straightforward in AT mode, but I want to build a network with 1 xbee/coordinator - N xbee/relay modules, so I have to use API mode, right?
asked Dec 28, 2015 in ZigBee PRO Featureset (and legacy ZNet 2.5) by usego New to the Community (0 points)
recategorized Dec 28, 2015 by michaelt

Please log in or register to answer this question.

1 Answer

0 votes
No you can mix the two modes if you want or you can use all API or all AT. It is really up to you. But I would suggest doing a mixture of AT and API. That is, leave the coordinator in API but put the End devices in AT mode. This way you don't need to have more intelligence at the end device side to send the data.
answered Jan 4, 2016 by mvut Veteran of the Digi Community (15,323 points)
...