Home/Support/Support Forum/constant analog sample values for varying sensor values

constant analog sample values for varying sensor values

0 votes
In a project I am doing, I have to send analog readings of a soil moisture sensor through zigbee. I have connected the sensor Vcc to 5v and ground; the zigbee Vcc to 3.3v and ground. The analog pin of sensor to Txx pin of adapter on which the zigbee is mounter. On the coordinator zigbee, i/o packets are being recieved..but it is always giving value of "020a" or "020b" irrespective of the data from sensor(on xctu). I have also fed the analog data of sensor through voltage divider to keep it within 1.2v range..can you suggest what I am doing wrong??

(On connecting sensor directly to arduino the sensor reading vary in the range 300-1023...only issue is in the i/o packet received at coordinator)
asked Jan 20, 2016 in XCTU by kahoko New to the Community (1 point)

Please log in or register to answer this question.

2 Answers

0 votes
Which pin on the XBee module do you have your Analog data pin connected to?
answered Jan 20, 2016 by mvut Veteran of the Digi Community (15,320 points)
I have mounted the zigbee radio on an adapter that has five pins: reset , tx, rx, gnd and vcc.
I have connected the analog data pin of sensor to the tx pin of the adapter on which the zigbee is mounted.
0 votes
The configuration at router are:

atid 5d2
atdh 0013a200
atdl 40d6a83f
atjv1
atd02
atir64
atwr
answered Jan 21, 2016 by kahoko New to the Community (1 point)
Tx and Rx are UART or COM port lines.  They are not lines that you can connect an Analog Pin to.  You need to connect the Analog line to D0 (Pin 20) since that is the Analog line you enabled.
Thanks a lot. I will try that out. :). Thank you for your help .
...