Home/Support/Support Forum/Cannot Launch PBuilder
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Cannot Launch PBuilder

0 votes
In my project, I was able to use PBuilder when my web\webcontent folder was placed in the root (root\web\webcontent)

I have now moved the web\web content folder from the root to a user created folder (root\Userfolder\web\webcontent) and thereafter, I am unable to use the Pbuilder.

I get warning " All files to be converted into C source code have to be inside project folder web\webcontents"

how would I get PBuilder to work again??
asked Jan 22, 2016 in NET+OS by anonymous
edited Jan 22, 2016

Please log in or register to answer this question.

1 Answer

+1 vote
Hello,
Please see the "PBuilder Tutorial" in DigiESP. Under "Help" search for "PBuilder" and select "PBuilder Tutorial"

NET+OS Project Structure:
PBuilder needs a folder structure to be launched. All PBuilder resources, input and output files must be inside a folder called "web" in the project "root" directory. This folder contains:
1. Folder "webcontents" contains files to be converted, PBuilder configuration file, PbSetUp.txt, and user dictionary file, RpUsrDct.txt.
2. A custom PBuilder batch file: *.pbb. If this file does not exist all webcontents folder will be compiled.
3. Folder result where PBuilder output files are stored. It is automatically generated when PBuilder is launched.
If folders web or webcontents do not exist, PBuilder cannot be launched.
To continue, click the Click when complete cheat sheet button.
answered Jan 25, 2016 by Campbell Veteran of the Digi Community (683 points)
...