Home/Support/Support Forum/How do connect to a non-digi Zigbee device using CP X4 and pull data?

How do connect to a non-digi Zigbee device using CP X4 and pull data?

0 votes
Hello there,

I am looking to bind my Ti CC2650 SensorTag with my Digi Gateway and pull temperature data from it. The sensortag uses the HA profile for Zigbee and uses Cluster 402, Profile 302 for temperature. I currently am having troubles binding the two and receiving messages from the device. In particular making the Digi X4 ask the 2650 to send messages properly.

My code is as follows:

DESTINATION=("00:12:4b:00:07:b5:64:81!", 0x09, 0x0302, 0x0402)
# Create the socket, datagram mode, aps transport: or should this be api?
sd = socket(AF_XBEE, SOCK_DGRAM, XBS_PROT_APS)

# Bind to endpoint 0x07 on gateway:
sd.bind(("", 0x07, 0, 0))
print "Bound now getting Temperature"
# Send "Hello, World!" to the destination node, endpoint,
# using the profile_id and cluster_id specified in
# DESTINATION:

sd.setblocking(False)

SentMsg = sd.sendto("Hello World!",0,DESTINATION)

Msg,add = sd.recvfrom(255)
print Msg
if Msg:
content = Msg[7:-1]
print("Msg: " + Bites.itemint(content, Msg))


For now I just want to see the Hello World come back but apparently the error "11, No more processes" suggest that I may be doing something wrong. Am I way off here? Or is there something I have totally missed? The Digi documentation does a really good job of hiding non xbee references. I have tried using DDO parameters like the zigbee.ddo_get_param() and it doesnt seem to work. Returns error fetching DDO param. Do i have to send a string of API or AT commands in sendto to get the temp data?

Any help is greatly appreciated.
asked Jan 29, 2016 in RF Solutions and XBee by Jnbijak New to the Community (8 points)

Please log in or register to answer this question.

2 Answers

0 votes
I guess Connect Port X4 modules that you posses, have XBee S2B module inside it. As of now, only XBee S2C modules are HA profile ready.

XBee S2B modules supports Digi's Drop In Networking profile, Zigbee 2006 & 2007 feature set only.
answered Feb 1, 2016 by asgm Veteran of the Digi Community (1,408 points)
If that is the case then how come I can still see the device?
0 votes
Hi, I have your same goal to reach.

But as a first step ... how do I configure the CPX4 with the Zigbee HA profile (with XCTU or CPX4 IP web access) to comunicate with CC2650STK.

Thanks...
answered Apr 24, 2018 by filippoN New to the Community (2 points)
...