Home/Support/Support Forum/router receive delay

router receive delay

0 votes
I have a plobrem.
current status :
1. pairing between coordinator and router.
2. Data send once a second
3. data send from router to coordinator -> ok
4. data send from coordinator to router -> happend delay.

I don't know why happend delay time~

What a way to fix this?

please help me
asked Feb 15, 2016 in XBee Programmable Development by chris.jeong New to the Community (2 points)

Please log in or register to answer this question.

2 Answers

0 votes
 
Best answer
I guess you have not changed default destination addressing on Coordinator.

By default, Coordinator sends data on broadcast address 0xFFFF. Change "DH" and "DL" parameter on Coordinator to match it with "SH" and "SL" of Router respectively. This should solve your issue in my opinion.
answered Feb 15, 2016 by asgm Veteran of the Digi Community (1,499 points)
selected Feb 15, 2016 by chris.jeong
Thank you for your reply

 I was try to your answer.
 GREATE!!

 but I must be use many router.
 ( 1 : N )

 so I think that Coordinator settings 0xFFFF.

 please help me~
0 votes
Thank you for your reply

I was try to your answer.
GREATE!!

but I must be use many router.
( 1 : N )

so I think that Coordinator settings 0xFFFF.

please help me~
answered Feb 15, 2016 by chris.jeong New to the Community (2 points)
In that case, you have to live with this time delay. There is not much in user's hand on broadcast packets.
If you only have a few routers, then using API mode and Unicast addressing would be well worth it.  You could then send the data to each node faster than using the broadcast address.  However, if you have more than 40 or so, it may not be worth switching to Unicast and API mode as the rout discovery may star to be too much.
...