Home/Support/Support Forum/Dynamic ip on pppoe interface
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Dynamic ip on pppoe interface

0 votes
Hello,

i am using wr21, primary interface is pppoe and secondary cellular mobile.

I have problem becouse my primary pppoe interface every 24 hours change ip address so conection is broken an after few seconds established again. in that few seconds celluar inerface is coming up. How to put in fonciguration so that while changing ip adress on pppoe interface cellular inertface stay down.

Please provide me solution for my question.

this is little part of event log.

21:42:06, 20 Feb 2016,Default Route 0 Available,Activation
21:42:06, 20 Feb 2016,PPP 0 Available,Activation
21:42:06, 20 Feb 2016,PPP 0 up
21:42:05, 20 Feb 2016,PPP 0 Start IPCP
21:42:05, 20 Feb 2016,PPP 0 Start AUTHENTICATE
21:42:05, 20 Feb 2016,PPP 0 Start LCP
21:42:05, 20 Feb 2016,PPPOE 0 PPP Session Established with HTdsl
21:42:05, 20 Feb 2016,PPPOE 0 Discovery Started
21:42:02, 20 Feb 2016,Eroute 0 VPN up peer: co035vpn
21:42:02, 20 Feb 2016,New IPSec SA created by co035vpn
21:42:02, 20 Feb 2016,DynDNS 0 host 0 updated: good 37.244.169.14
21:42:02, 20 Feb 2016,(4408) IKE Notification: Initial Contact,RX
21:42:02, 20 Feb 2016,(4409) IKE Notification: Responder Lifetime,RX
21:42:02, 20 Feb 2016,(4408) New Phase 2 IKE Session 195.29.121.116,Initiator
21:42:01, 20 Feb 2016,GP socket connected: 37.244.169.14:25939 -> 204.13.248.111:80
21:42:01, 20 Feb 2016,(4407) IKE Keys Negotiated. Peer: co035vpn
21:42:01, 20 Feb 2016,TCP Req: 37.244.169.14:25939 -> 204.13.248.111:80
21:42:01, 20 Feb 2016,(4372) IKE SA Removed. Peer: co035vpn,Tunnel Down
21:42:01, 20 Feb 2016,(4407) New Phase 1 IKE Session xxxxxx,Initiator
21:42:01, 20 Feb 2016,IKE Request Received From Eroute 0
21:42:01, 20 Feb 2016,SMTP req by CMD email event.eml
21:42:01, 20 Feb 2016,Eroute 0 VPN down peer: co035vpn
21:42:01, 20 Feb 2016,IPSec SA Deleted ID co035vpn,Interface to destination
21:42:01, 20 Feb 2016,PPP 1 up
21:41:58, 20 Feb 2016,PPP 1 Start IPCP
21:41:58, 20 Feb 2016,PPP 1 Start AUTHENTICATE
21:41:58, 20 Feb 2016,PPP 1 Start LCP
21:41:58, 20 Feb 2016,PPP 1 Start
21:41:58, 20 Feb 2016,Modem connected on asy 2
21:41:57, 20 Feb 2016,Modem dialing on asy 2 #:*98*1#
21:41:57, 20 Feb 2016,IP Act_Rq to PPP 1-0: s_i
21:41:57, 20 Feb 2016,Default Route 0 Out Of Service,Activation
21:41:57, 20 Feb 2016,PPP 0 Out Of Service,Activation
21:41:57, 20 Feb 2016,PPP 0 down,Remote disconnect
21:41:57, 20 Feb 2016,PPPOE 0 PPP Session Terminated,Remote request
asked Feb 21, 2016 in Digi TransPort Cellular by iadamovic New to the Community (5 points)

Please log in or register to answer this question.

2 Answers

0 votes
Have you reviewed App Note 41? It seems related to the scenario you're describing.

http://ftp1.digi.com/support/documentation/AN_41_Eth_Backup_to_WWAN.pdf
answered Feb 22, 2016 by jeremym Veteran of the Digi Community (1,673 points)
0 votes
Yes, i saw document. But, as you see in event log.
While changing ip address

21:41:57, 20 Feb 2016,Default Route 0 Out Of Service,Activation
21:41:57, 20 Feb 2016,PPP 0 Out Of Service,Activation
21:41:57, 20 Feb 2016,PPP 0 down,Remote disconnect
21:41:57, 20 Feb 2016,PPPOE 0 PPP Session Terminated,Remote request

and then after 1 second PPP 1 interface is up.
I dont want to be up immediately. I want to achive to not be started while changign ip address on PPP 0 interface.

as you see ppp 0 interface is started again after 8 seconds.

where is option for achieving that?
answered Feb 23, 2016 by iadamovic New to the Community (5 points)
if you have PPP 1 in advanced configuration inhibit its self if PPP 0 is "'active and not OOS'"

tin PPP 0 advanced configuration there is a setting

"If this PPP interface gets disconnected, allow it to attempt to reconnect  times before allowing other PPP interface inhibited by this interface to connect "

set this to 1

this should keep PPP 1 down while PPP 0 has 1 attempt to reconnect after that attempt PPP 1 will come up


regards
i put configuration as you instruct, it doesnt work. it always brig up ppp1 while changig isp ip on ppp0.

maybe problem is in this. when i put in advanced on ppp 1 "Inhibit this PPP interface if the following PPP instances 0  "active and not OOS"" it's dont remember that it show only "Active". whay it doesnt remember my configuration when i put  "active and not OOS".

regards
...