Home/Support/Support Forum/Mesh network, router mode, sometime can't join to network

Mesh network, router mode, sometime can't join to network

0 votes
I'm using mesh topology with Zigbee pro stack profile
there is a 1 coordinator and about 200 of Routers in my network and the problem is sometimes some routers can't join to network, the coordinator can't connect to them but sometimes the routers that can't join to network will be able to join back to network again.

Please suggest what should I do for this. I may set the wrong configuration to routers or coordinator device.

Thank you
Best Regards,
asked Feb 29, 2016 in IEEE 802.15.4 by batteria New to the Community (1 point)
edited Feb 29, 2016 by batteria

Please log in or register to answer this question.

2 Answers

0 votes
Why are you resetting a network of that size to begin with? You most likely need to adjust the SC, ZS,NW and JV commands on your router to keep them from loosing association.
answered Feb 29, 2016 by mvut Veteran of the Digi Community (12,006 points)
First, thanks for your answer.

   my application is smart streetlight. So, there is no power to all nodes between 6am to 6pm.
Are you controlling the power distribution main before it goes out to the lights on the roads? If the XBee is mounted on the Street light and you are controlling the main, then what function is the XBee providing?  Generally in these types of applications, it is the processor connected to the XBee or the XBee's DIO functions that is turning off and on the light and not the main that is being controlled externally.
We didn't control the main power, we just use it for dimming function and read power usage, voltage, current.
The solution is using XBEE with MCU, the mcu will control streetlight and wait for command from server that will control the streetlight via xbee.
So again the question is, why are you resetting a network of that size? What settings have you changed from their default values? What firmware versions are you working with?
We can't control the main power, it will operate from 6pm to 6am. Then, it will be reset everyday.
please check the configuration here.
0 votes
This config. for routers.
please be informed, there are 2 type of router, S2 and S2c in my project.

<description_file>xb24-s2c-th_4059.xml</description_file>
<settings>
<setting command="ID">100</setting>
<setting command="SC">10</setting>
<setting command="SD">7</setting>
<setting command="ZS">2</setting>
<setting command="NJ">FF</setting>
<setting command="NW">1</setting>
<setting command="JV">0</setting>
<setting command="JN">1</setting>
<setting command="CE">0</setting>
<setting command="DO">0</setting>
<setting command="DC">0</setting>
<setting command="DH">0</setting>
<setting command="DL">0</setting>
<setting command="NI">0x20</setting>
<setting command="NH">1E</setting>
<setting command="BH">0</setting>
<setting command="AR">FF</setting>
<setting command="DD">A0000</setting>
<setting command="NT">3C</setting>
<setting command="NO">0</setting>
<setting command="CR">3</setting>
<setting command="SE">E8</setting>
<setting command="DE">E8</setting>
<setting command="CI">11</setting>
<setting command="TO">0</setting>
<setting command="PL">4</setting>
<setting command="PM">1</setting>
<setting command="EE">0</setting>
<setting command="EO">0</setting>
<setting command="KY"></setting>
<setting command="NK"></setting>
<setting command="BD">3</setting>
<setting command="NB">0</setting>
<setting command="SB">0</setting>
<setting command="RO">3</setting>
<setting command="D7">1</setting>
<setting command="D6">0</setting>
<setting command="AP">1</setting>
<setting command="AO">0</setting>
<setting command="CT">64</setting>
<setting command="GT">3E8</setting>
<setting command="CC">2B</setting>
<setting command="SP">20</setting>
<setting command="SN">1</setting>
<setting command="SM">0</setting>
<setting command="ST">1388</setting>
<setting command="SO">0</setting>
<setting command="WH">0</setting>
<setting command="PO">0</setting>
<setting command="D0">1</setting>
<setting command="D1">0</setting>
<setting command="D2">0</setting>
<setting command="D3">0</setting>
<setting command="D4">0</setting>
<setting command="D5">1</setting>
<setting command="D8">1</setting>
<setting command="D9">1</setting>
<setting command="P0">1</setting>
<setting command="P1">0</setting>
<setting command="P2">0</setting>
<setting command="P3">1</setting>
<setting command="P4">1</setting>
<setting command="PR">1FBF</setting>
<setting command="PD">1FFF</setting>
<setting command="LT">0</setting>
<setting command="RP">28</setting>
<setting command="IR">0</setting>
<setting command="IC">0</setting>
<setting command="V+">0</setting>
</settings>
answered Mar 9, 2016 by batteria New to the Community (1 point)
You really need to switch to the Digi Mesh products over a Zigbee mesh.  Zigbee mesh networks of this size really don't want to be re-started on a regular basis.
...