Home/Support/Support Forum/Trouble migrating from XBee S2/Pro S2B to XBee S2C Smt

Trouble migrating from XBee S2/Pro S2B to XBee S2C Smt

0 votes
I several working devices using the through hole version of the XBee S2 and S2B Pro. Now migrating to put my device on a PCB, I had to switch to the S2C. According to the datasheet it should be pretty much the same, but I've been fighting to communicate with the S2C for a while now. On the S2/S2B I only used pins DOUT, DIN, and DTR, as well as having VREF to GND. The rest are not hooked up. I wired the S2C the same way and I've been trying to communicate to the S2C with no success. I've tried every baud rate possible, and all I get back from the UART is garbage. Please help! Is there a recommended way I should connect to my S2C? Thanks for your help!
asked Mar 9, 2016 in XBee Programmable Development by devWarrior New to the Community (1 point)

Please log in or register to answer this question.

1 Answer

0 votes
What is the full part number of the S2C you are working with?
answered Mar 9, 2016 by mvut Veteran of the Digi Community (15,323 points)
I'm not sure if this is the part number or serial number:

XB24CZ7PISB003-revH0013A20040C78683
That is the programmable version of the module and not the direct replacement. The Direct replacement would be an XB24CZ7PIT-003.
What's the difference? How would programming it be different? Isn't it just surface mount version?
The programmable has a 2nd processor on it that is between the XBee pins and the RF processor.  It is designed for customers to are using a small external processor the ability to drop that external process and port their code to the XBee instead.   The other version which is the Non programmable is what you want.
That makes sense now. Would the XB24CZ7PIS-004 work? It looks like that one isn't programmable, and it's a surface mount. Thanks so much for your help!
Yes it would.
Thanks so much for the help! I have one last question before I make a new pcb. Do I need capacitors from vcc to gnd? Some of the xbee development boards have them, but the datasheet doesn't say anything about them. Are they necessary? If so, what values should I be using?
I can't answer that.  They are basically used to filter the power line and provide enough current when the radio wants to transmit.  So you are going to need to look at your ripple on your line and make the determination if you need to clean it more or not.  You then also need to look at the slew rate of your power supply to make sure that it can provide the Peak power the radio wants when it wants it.
...