Home/Support/Support Forum/XCTU cannot find firmware

XCTU cannot find firmware

0 votes
when i try to select my xbee from the list in XCTU, There is a message that xctu can't find the firmware do u want to update ? i tried update hundreds of times from remote server and also local file downloaded from digi.com. but again i face with this error. i also tested recovery but nothing fixed. please help
asked Mar 17, 2016 in ZNet 2.5 by joomtalk New to the Community (2 points)

Please log in or register to answer this question.

1 Answer

+1 vote
Best answer
When you query the radio, what firmware version is installed on it? What is the full part number of the XBee you are working with?
answered Mar 17, 2016 by mvut Veteran of the Digi Community (12,584 points)
selected Mar 17, 2016 by joomtalk
The problem is that there is no firmware installed.  It seems it is corrupted. I am trying to restore it but no chance. I followed istructable for reseting bee but noting happened.
The part number I am looking for would be something like XBP24-Z7SIT-oo4 and will be on the white label.
I have two module.
one of them is :
Sounds like the firmware that is installed on your module is on the older side.  I would suggest following the steps outlined at http://knowledge.digi.com/articles/Knowledge_Base_Article/Recovery-procedure-for-ZigBee-XBees/?q=xbee+recovery&l=en_US&fs=Search&pn=1 to install the most current version (2xA7).
Thanks man it worked....u saved me:)