Home/Support/Support Forum/XBee DIO Adapter shorts power supply when pin 1 - 4 goes high 12 vdc

XBee DIO Adapter shorts power supply when pin 1 - 4 goes high 12 vdc

0 votes
Hi,

We setup a Xbee digital DIO adapter (9 - 30 vdc) to send a message when pin 1 - 4 goes high or low using state change. The voltage applied to pin 1 - 4 is 12 vdc, When 12 vdc is applied the device sends state change (pin high) message, shorts power supply, sends state change (pin low) message. As soon as we switch on 12 vdc power supply dies. When using 6 vdc on pin 1 -4 and switch pin to high, voltage drops from 6vdc - 2.7 vdc and messages are sent correctly. All dip switch are set to off, all DIO used pins are disabled except pins used for input and these are set to 3. This is not the expected behavior as described to us about the adapter.Anyone have any information that may explain this behavior?

Thanks in advance.
-albe
asked Mar 20, 2016 in RF Solutions and XBee by albe New to the Community (4 points)
edited Mar 20, 2016 by albe

Please log in or register to answer this question.

1 Answer

0 votes
Have you been over page 37 of the manual located at http://ftp1.digi.com/support/documentation/90000891_J.pdf ?
answered Mar 21, 2016 by mvut Veteran of the Digi Community (13,036 points)
Yes I have the device set per the manual. All pins are disabled but the input pins per digi when we purchased the DIO adapter.
Did it ever work properly or is this a new install?
Thanks for your reply. New install.
I would suggest talking to Digi technical support as it may need to be replaced.
Thanks again for your assistance..
...