Home/Support/Support Forum/Why do some of my RCM4200 cores act like the ethernet is crossed over?
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Why do some of my RCM4200 cores act like the ethernet is crossed over?

0 votes
This is a follow-up to my previous question regarding non-functional ethernet in new RCM4200 cores. (not sure that one's going to be approved)

We found out the problem cores worked when plugged into an auto-crossover switch. Then we found out they worked when plugged into the Uplink port of a non-auto-crossover switch.

That makes it appear the the RCM4200 is crossed over. Is this a selectable option via hardware or software?

I've randomly had issues such as this over the years but never tracked it down until a bunch of my new Rabbits misfired.
asked Mar 24, 2016 in Rabbit by FolsomMike New to the Community (11 points)

Please log in or register to answer this question.

1 Answer

0 votes
Best answer
If you're using a beta of Dynamic C 10.72A, or the Open Source version on GitHub, it could be because of a bug in ASIX.LIB.

The version that shipped with DC 10.72 works fairly well, but a patch added to GitHub introduced a bug that affects how the ASIX Ethernet controller establishes link.

I pushed a fix up to GitHub last week, and it will be part of the official 10.72A release scheduled for this week.

answered Mar 28, 2016 by TomCollins Veteran of the Digi Community (2,222 points)
selected Mar 28, 2016 by FolsomMike
I have been using the 10.72 code available (sort of, if you search long enough) on digi.com. I only found out about the github move last week. I'll watch for the patch.

I now realize that I probably have been using auto-crossover hubs a lot of the time...and I nearly threw away a non-auto hub because it wouldn't work with any of my Rabbits. I just now caught this work-around.