Home/Support/Support Forum/Totally newbie, point to multi-point network: how to?

Totally newbie, point to multi-point network: how to?

0 votes
Hi guys, It's first time I try to work with XBee devices so I'm totally newbie.

I need to make a point to multi-point network:
- 5-6 remote sensors
- 1 server

Every device will be powered by Raspberry-Pi where I'll connect XBee module, preferred serial interface instead USB.
Every remote device will send data to central server, I'working in not direct-seight area, so I was thinking to 868 MHz, but actually my supplier can provide me only 2,4GHz modules I could use for tests.

I would like to be able to set some modules as repeaters (modules should be within less than 1km far from central server, but I can still have troubles, so I plan to place repeaters).

Central server has got internet connection to display data on webpage.

Now, I supposed to use XBee® 868LP as final module, but only XB24 is available for tests.

1) Can I set both modules for repeater function?
2) Once I send data to server through serial port (maybe in Python), can I get acknowledge central server has received data?

Thanks.
asked Mar 25, 2016 in RF Solutions and XBee by El Berto New to the Community (8 points)

Please log in or register to answer this question.

4 Answers

0 votes
What is the full part number of the modules you can order right now? Please provide it as it makes a big difference in what you would need to do.
answered Mar 28, 2016 by mvut Veteran of the Digi Community (12,653 points)
0 votes
Thanks mvut,
my available modules are:

- XB24-AWI-001
- XB24-AUI-001
- XB24-ACI-001
- XB24-BCIT-004
- XBP24-AWI-001
- XBP24-AUI-001
- XBP24-ACI-001

Taking a look to the comparison chart for EU use, compatible devices to 866LP should be (except frequency) only XBP24, right?
answered Mar 29, 2016 by El Berto New to the Community (8 points)
Except for the XB24-BCIT-004, all of the modules you are working with are the 802.15.4 XBee modules.  They support peer to peer (Default), point to point and point to multi-point network typologies.  The XB24-BCIT-004 is a Znet 2.5 module (Pre Zigbee) and will not communicate with the other modules you have.

In order to use the XBP24 modules in Europe, you will need to set the PL command to a value of 0 (10mW).

The default configuration of the XBee 802.15.4 modules does not support a Repeater network.  In the 802.15.4 standard, repeaters or routers only exist in the networking layers which operate above the 802.185.4 PHY and MAC layers.

If you require a Mesh network with Repeaters or Routers to extend the range, you may be able to re-flash the firmware on your XBee 802.15.4 modules to the Digi Mesh 2.4 firmware.  You can do this by using the XBee Recovery function in XCTU and select either the XB24-DM (1mW) or the XBP24-DM modem types.
0 votes
I discovered there is available XBP08-DPSIT-024 module from UK; except high power (and consumption), could I re-flash firmware to Digi Mesh?
If not I think I'll buy XB24-AWI-001 (would be the same XB24-Z7WIT-004 module?) for tests before the 868LP...
answered Mar 30, 2016 by El Berto New to the Community (8 points)
No that module does not support Digi Mesh.

No, the XB24-AWI and XB24-Z7WIT are not the same product.  They are two different XBee modules running different protocols. If you want to order a mesh version of the XB24-AWI module, then the part number would be XB24-DMSIT.
0 votes
Hi guys, I finally got XBIB-U-SS for my XP-868LP modules.
I need to create a point-to-multipoint network (central node is mains powered and receives data from remote battery-powered modules). In a second time I'll think about mesh network.

New modules factory defaults are router and digi-mesh.

If I need to change central node I need to re-program destination address on every node, so I suppose to use broadcast data.

Following example on XBee-868LP manual (90002126_B page 82) I send following data to module:

7E 00 16 10 01 00 00 00 00 00 00 FF FF FF FE 00 00 54 78 44 61 74 61 30 41 3C

Then I receive immediately answer:
7E 00 07 8B 01 FF FE 00 00 00 76

Transmit Retry Count = o
Delivery Status = 00 (Success)
Discovery Status = 00 (No Discovery Overhead)

But how could I get "success" if I am using only one module not connected to any module???????

If I use destination address 0x000000000000FFFE I correctly get answer after a couple of seconds:

Transmit Retry Count = 1
Delivery Status = 25 (Route Not Found)
Discovery Status = 02 (Route Discovery)

So, what's wrong?
answered Sep 8, 2016 by El Berto New to the Community (8 points)
...