Home/Support/Support Forum/How do I disable a serial port on the ConnectPort LTS 32
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

How do I disable a serial port on the ConnectPort LTS 32

0 votes
I need to disable a serial port on a ConnectPort LTS 32 to plug a security hole but I have been unable to find anything in either the command line or the web interface to do this. Is it possible?

Thanks in advance.
Phil.
asked Apr 6, 2016 in ConnectPort TS by phil6564 New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
You can turn off ports/sockets via the 'set service' command via the LTS command line:
#> set service ?
answered Apr 6, 2016 by ronk Community Contributor (126 points)
Thanks for your reply ronk. I think, however, that the set service command is to set network services parameters, rather than the physical port. I am looking to disable a physical port. Any ideas?
No I do mean 'set service'. This allows you to close specific sockets per port. There is no general disable of port. But you can close all services allowed for the port.

Maybe we should be more specific. Exactly what socket(s) do you need closed?
I need to close all services on that physical port so as to effectively disable it.

If I do the "show service range=1-270" command I get the following for port 32, which is the one I need to disable:

263   off  2032       off     off      200              Telnet Server(Port 32)
264   off  2132       off     off      200                 TCP Server(Port 32)
265   off  2132       off     off      200                 UDP Server(Port 32)
266    on  2532       off     off      200                 SSH Server(Port 32)
267   off  2632       off     off      200      Secure Socket Service(Port 32)
268   off 50032       off     off      200            Modem Emulation(Port 32)
269   off  none      none    none     none            RealPort Service(Port 1)
270   off  none      none    none     none                         LPD(Port 1)

Evidently only SSH is active on this port (service 266) so is it simply a case of doing something like the following to disable it:

set service range=266 state=off
...