Home/Support/Support Forum/Initial console to DIGI, portserver II/16. what is the cable pinout?
New and improved user forum site going live on 12/6 (All users will need to reset their password when the new forum is active)
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Initial console to DIGI, portserver II/16. what is the cable pinout?

0 votes
I have a home-grown "datacenter" of mixed devices, SUN/AIX/HP/Cisco/Adtran/Juniper, etc. I bought 2 Digi Portserver II 16 so I could reduce the cable clutter. I checked the manuals for console connectivity on initial setup, and bought the shells assemble the cables. I have yet to get a successful session on either of the digis. If I power them on, I do see a character appear on the screen so there is some type of connectivity. On my end, Im using a USB to serial adapter and DB9 to RJ45. The adapter blanks I bought have RJ45 pin 1 and pin 10 empty. Colors in sequence beginning at 2 are gray green black blue white yellow red orange. I've tried 3 different pinouts already based on suggestions from various internet groups, finally decided to join here and get (hopefully) a good answer so I can stop wasting adapters with different non-functioning pinouts. Just to clarify this is to connect to the digi, for initial setup/configuration. Any assistance would be greatly appreciated.
asked Apr 20, 2016 in Console Servers by dfekigjkh New to the Community (6 points)
edited Apr 20, 2016 by dfekigjkh

Please log in or register to answer this question.

4 Answers

+1 vote
Have you factory reset the unit to ensure the serial ports are available for login?

answered Apr 21, 2016 by userid0 Veteran of the Digi Community (2,158 points)
Thanks for the info. I reset it, now it shows P0 on the front. When I power cycled it, I got a character on the terminal display, but no login prompt,so I'm guessing this particular pinout is invalid, which means I'm back to my initial question, but one step closer since I should be able to log in when I finally get the pinout right. Thanks.
+1 vote
P0 is not normal, the unit should show AC. The unit may be in need of repair.
answered Apr 22, 2016 by userid0 Veteran of the Digi Community (2,158 points)
My mistake. I reset it again. It paused on P0, then after about 5 seconds resumed and went to AC.
Have you tried logging into other ports besides 1?   The settings are defaulted to 9600 baud, 8 character bits, 1 stop bit, no parity.  Make sure you are using crossover (null modem) cable.  If you still don't get a login prompt, it would indicate a problem either with the serial ports on the unit or the cable.
I suspect the problem is with the cable pinout, which was why I asked about pinout in my original question.
What device are connecting to the serial port currently?  It is important to note that the Cisco/Sun cable ends are not interchangeable and should be labeled, the Cisco/Sun end needs to plug into those devices, while the other end into the Digi port.
I haven't connected any devices to the digi yet. It's temporarily on my desk in my office so I don't have to go up and down stairs repeatedly while I'm trying to troubleshoot/configure. I wanted to do the initial network config and test connectivity before I start adding devices. As I've said, I don't even get a login prompt.
The cabling pinouts depend on what you are attaching to the serial ports.  If you are connect a PC with a DB9 connector:


DB25 PC connection:


Cisco/Sun Console:


*Note the cable ends are not interchangeable.

The ports are set for 9600 baud, 8 character bits, 1 stop bit and no parity by default.

If you continue to experience problems, you might want to consider purchasing a cable/adapter from Digi.
0 votes
Most of these, with the exception of the AIX console, will require specific pin-outs:


AIX would use a standard null-modem (crossover cable), however carrier is required on this OS:
answered Apr 20, 2016 by userid0 Veteran of the Digi Community (2,158 points)
Thanks for the response. I'm afraid I didnt phrase my question accurately. i have pinouts for the clients, I'm just having no success connecting to the digis for the initial configuration. As I mentioned, I've tried 3 different pinouts to attempt a connection on port 1 of the digi in order to configure the digi ports for the clients, but I haven't gotten a response on the term to do even an initial login.
0 votes
UPDATE: I managed, thanks to Professor Google, to get a working pinout, was able to log in, set the password, etc. Now my issue is how to test port configurations. I'll post this as a separate question. Thanks to everyone who answered.
answered Apr 26, 2016 by dfekigjkh New to the Community (6 points)
edited Apr 28, 2016 by dfekigjkh
I know its been 5 years but I have recently ran into the same problem... Do you remember the pin out for the portserver II I can't find the correct pin out to login...