Home/Support/Support Forum/How to test client connectivity from digi
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

How to test client connectivity from digi

0 votes
I'm attempting to configure ports on a portserver II. Since I have different types of hardware which take different cable pinouts, I would like to "step out" the connection, beginning with digi to local port, then remote to digi. The reason I'd like to do that, of course, is to ensure the cable works going out to the device. Help doesnt seem to show a command that would work (I was told "connect port#" was how to do it, but if that had worked, I wouldn't be here again). So, to reiterate, can someone confirm that I can connect, while logged in to the digi as root, to a port to verify connectivity, or was my helpful advisor way off base?
asked Apr 28, 2016 in Console Servers by dfekigjkh New to the Community (6 points)

Please log in or register to answer this question.

1 Answer

+1 vote
Yes, you can use connect from the root prompt of the PortServer II in order to connect to the attached serial device.

For example:

#> connect 1

will connect to port one and allow you to communicate with the connected serial device. Pressing <Ctrl>-[ will allow you to return to the root prompt. Typing close from the prompt will close the port connection or you can type reconnect from the prompt to reconnect to the port.

More information on console management configuration is available here:

answered Apr 28, 2016 by userid0 Veteran of the Digi Community (2,158 points)
I'm thinking one of my digis has a problem. the connect command works on my 2nd digi, but not on the one I had been testing. thank you very much for your response. I was able to confirm that the cable I built for the cisco router works.  Obviously my config is correct yet since I can't connect by ssh to the port (i.e. to $user@$diginame -p 7002). I have about 20 more devices to connect. Once I verify the cables are all good, I'll try to figure out why I cant ssh to the port. Thanks again.
Just to be clear, the old obsolete PortServer II unit does not support SSH.  What product are you using exactly?  Do you have a part number?
My apologies, I didn't type a full description of the problem. The reason I think it's a config issue is I can't connect with telnet either, which is what I tried first. I can log on to the digi, but I can't connect to port 2, which is where I have the first test device. I've verified I can connect from the digi directly with the connect command (thanks again for confirming that). One add'l question, telnet will suffice for my purposes, but at what model did digi's begin supporting ssh? I asked professor google without success.
What error is seen when trying to telnet?  What error is seen when using the connect command?  

Is the dev setting configured as prn?  Was the device rebooted after changing the dev setting to prn?

The PortServer TS model is the first to support SSH.
The connection times out (which is an improvement, since I was getting connection refused).
Settings for port are:
#> set port range=2
tty  termtype   dev sess  uid edelay auto  bin  group  dport            dest

  2     vt100   prn    4    0      1  off  off      0      0

Settings for line are:
#> set line range=2
tty  baud  csize parity stopb  break      error inpck istrip onlcr otab

  2   9600    8     N     1     send       null   off   off   off   off
What does "set auth" show?

Also, the results from the "who" command.
Unfortunately the digi for which I asked this question is now Tango Uniform. My other functional digi doesn't support the connect command so I can't verify that it can even connect to the test client. At this point I'm awaiting delivery on my last test digi. Should I be unable to get it to work, I've decided to move to a different console solution. I wanted to buy Digis because the portserver II models are in use by my employer, so I was familiar with them. I failed to factor in the age, and apparently, difficulty, of config. Thanks for all of your help.