Home/Support/Support Forum/firmware upgrade fails
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

firmware upgrade fails

0 votes
I have a portserver II, 50000309-02. Attempting to upgrade the firmware. I set the boothost and bootfile to the tftp server, then restart. The tftp server logs show repeated successful Gets, "Started file name: xxx" followed by "Completed, file name: xxx". This process continues for as long as I allow it, with the digi never actually proceeding to install the firmware. I tried my initial guess at the right firmware, 4001260p.bin, since that is listed as "Part# 50000309 < Rev.K or 2meg prom). I'm not sure how/if Rev K relates to 5000309-02.
At any rate, as usual, any assistance would be greatly appreciated.
asked May 3, 2016 in Portserver (CLI-only) by dfekigjkh New to the Community (6 points)

Please log in or register to answer this question.

1 Answer

0 votes
What operating system version is acting as the tftp server?

Unix: http://ftp1.digi.com/support/firmware/tftpboot.txt

Windows: http://knowledge.digi.com/articles/Knowledge_Base_Article/Digi-PortServer-II-Firmware-Upgrade

Are you running the boot load command?
answered May 3, 2016 by userid0 Veteran of the Digi Community (2,158 points)
The instructions in your KB article are different from the ones on the firmware download page. The doc I was using had me set boothost, bootfile, tftpboot=smart and then b a=r, after which the digi hung, and since the instructions were to do the boot load command after boot, I never got to that step.
    When I tried the doc you included, I got a successful load, but after resetting, the digi is going through a continuous P0/PE/8.8 cycle. I tried to reset to factory defaults, but it looks as if this digi is now an expensive paperweight.
    BTW, the initial instructions I found were on the support page for downloading the firmware
I'm not exactly clear on the difference between the knowledge base and the firmware text file you are referencing for Unix tftp.  They look the same to me.

Did you confirm the firmware load was successful after rebooting and before doing the boot load?  This is only supposed to run the boot load command after you verify you were able to boot from the new firmware image.  If this was the case, it may be possible that the hardware simply went bad - Digi has not sold these units for a long time (12 years or more).

Since the unit will no longer boot, you may need to check with Digi to see if the device can be repaired.
Your statement about running boot load after verifying the ability to boot from the new image matches the doc that's on the firmware page (the one I was originally using). The doc you sent me has instructions to set the boothost, set the boot file, then do boot load, and after it's complete, reboot and verify the new image:
5.   Log in as Root.

6.   The default password is dbps.

7.   At the command prompt (#>) type set config boothost=<ip address of system being used to update the
      firmware> bootfile=<path to firmware>
      For Example: set config boothost= bootfile=C:\40001260_AB.bin

8.   Hit Enter.

9.   At the command prompt (#>) type boot load=xxx.xxx.xxx.xxx:firmware.bin.  
      NOTE: xxx.xxx.xxx.xxx is the IP Address of the server running TFTP.
      NOTE: Make sure you add the ***** between host IP address and firmware file.
      For Example: boot load= and press Enter (see Figure 3).  You''''ll see the
After the boot load (skipping the embedded pics):
8.   Watch the TFTPD.exe screen for transfer status (see Figure 4).
9.   You will get a Transfer Complete! message when it is finished (see Figure 5).
10. On the Telnet session, you should see something like this: (see Figure6).
11.  Reboot the PortServer II product.

12.  If you telnet back into the PortServer (II) product and issue a set config command after logging in,
       you can verify the firmware has been upgraded, by checking the version.
       NOTE: It will say something like "PortServerII Version 3.1.12 January 14, 2002" depending on your
So basically the two docs are different. At any rate, thanks for the assistance. I won't be doing any firmware upgrades any time soon since I don't want to keep replacing digis. Unfortunately the remaining digi I have doesn't seem to support the "connect $Port" command, probably because it has an image 2 years older than the one that just died. I'm awaiting delivery on another digi that I ordered a few weeks ago. I really would like to stick with the portserver II, but if I can't get the new one to work, can you perhaps recommend another model that has 16 ports and doesn't cost several limbs and a major organ?