Home/Support/Support Forum/XCTU Firmware Library Error

XCTU Firmware Library Error

0 votes
The following error occurs everytime I try to update the Firmware Library.

Checking for Radio Firmware Uupdates has encountered a problem.

Error while loading firmware library:, "C:\Program Files(x86)\Digi\XCTU-NG\radio_firmwares". Invalid XML contents.

OK Details
asked May 4, 2016 in XCTU by LarryBotts New to the Community (4 points)
I just started getting this error this week. I have been noodling with the legacy XCTU as well based on recovery guidance in KB for programmable Xbee. All of sudden today I started getting this error on the current XCTU version.

Please log in or register to answer this question.

6 Answers

+1 vote
Hi, I am having the same problem. Have been using the latest version of XCTU now for about a month (Mac and Windows 10). Same problem started this morning.
answered May 5, 2016 by mdunbar New to the Community (3 points)
+1 vote
Win10, XCTU-NG. While trying to update firmware library, a recurring error as shown above. I have uninstalled 3 times, and reinstalled, to no avail. Is this a bug or should I consider it my error. I notice at least one other person having the same problem.
answered May 9, 2016 by LarryBotts New to the Community (4 points)
0 votes
I had the exact same issue. I was trying to make some changes to the configuration of the radio, I got the error message when I clicked on the radio module.
I tried several different things, eventually one worked!
I used an older version of X-CTU and was able to make changes. After I saved the changes, now the radios work. But I still cannot go to the settings with the newer version of the XCTU. I believe it is a software bug in X-CTU.
answered May 13, 2016 by Wei New to the Community (1 point)
0 votes
I spent a week interacting with the Digi Support team on this issue for me. XCTU-NG was working fine for over a month and then I started getting this error. After working with them it turned out that I didn't have rights to a certain directory. Running as Admin when launching the tool solved the problem.

I launch by shift right clicking on the item and "run as administrator". It works perfectly now. Of course, I shouldn't need to run as admin so still need to ponder that.
answered Mar 31, 2017 by dpguitarman New to the Community (6 points)
0 votes
Hello, I am having the same problem as all of you. Does anyone have found any solution to this problem?
answered Aug 11, 2017 by AiSis New to the Community (1 point)
0 votes
According to the release notes for the latest version of XCTU, it checks for the latest firmware before connecting to the device. If it can't find the library you won't connect. I downloaded the library and put it in the same folder as XCTU and now I can connect.
answered Jun 26, 2018 by stro1rob New to the Community (1 point)