Home/Support/Support Forum/Any known problems with XIG for Windows?
New and improved user forum site coming soon

Any known problems with XIG for Windows?

0 votes
I have tried running both XIG for Windows Versions 1.5.1 and 1.5.2.

In both cases, xig_app.exe throws the following error -

Error opening socket: hostname 'my.idigi.com' doesn't match u'EDP Device Certificate'.

Is this a known problem or is there something that I have overlooked?

Sincere Thanks
asked May 10, 2016 in Device Cloud-enabled RF Gateways by JonFreeman New to the Community (4 points)

Please log in or register to answer this question.

1 Answer

0 votes
Have you followed the instructions here?


What Digi product(s) are you using?
answered May 12, 2016 by userid0 Veteran of the Digi Community (2,158 points)
edited May 12, 2016 by userid0
If you look here https://github.com/XBeeInternetGateway/XIG/releases you will notice that there are (broadly speaking) two versions of XIG -

One that works with the gateway (for example:  xig_connectport_1.5.2-py2.7.zip)
One that runs off a workstation (for example:  xig-windows-1.5.2.zip)

The windows version is described by Rob here https://github.com/XBeeInternetGateway/XIG/wiki/Windows-installation
This is reasonably useful as it allows you to communicate with the Internet without having to buy a gateway.

I am using a Series 2 so you will need to search for Hardware configuration ZB ZigBee (Series 2): (its somewhat embedded in the 802.15.4 content).

When I run xig_app.exe it opens a command line window and launches the default browser (IE in my case) and points to http://localhost:8000 to display the online user interface for the XIG.

Almost immediately, the command line window starts to display the error:  Error opening socket: hostname 'my.idigi.com' doesn't match u'EDP Device Certificate'.  The message is repeated in the browser.

There is a certificate in the downloaded directory (idigi-ca-cert-public.crt) but it is way out-of-date.  I am not sure if this is causing the problem.
Just a quick update on this one.  I swopped a mail with Rob and he is checking with the Digi Device Cloud folks to see if the problem is the certificate, the old domain name, or something else.
Any update on this... I use this in class to teach my students IoT... Do I need to switch to a different technology. Be a bummer as we bought a lot of xbees just for this.
I did a quick check and the problem still persists.  You may want to check with Rob Faludi who undertook to sort this out.
I didn't pursue the Windows version any further as I was able to get XIG to work with a gateway.  This had its own challenges (see http://www.digi.com/support/forum/55778/any-problems-with-xig-version-1-5-2-python-version-2-7).
Thanks Jon... I use a connectport at home but use the windows xig at school for my students. I just posted to the xig group to see if Rob had any advice.