Home/Support/Support Forum/Are the new 900 SX compatible with any of the previous 900 Mhz modules?

Are the new 900 SX compatible with any of the previous 900 Mhz modules?

0 votes
In particular, are they compatible with the 900 XTEND products?
asked May 19, 2016 in RF Solutions and XBee by bigredbee New to the Community (1 point)

Please log in or register to answer this question.

1 Answer

0 votes
Yes there are SX versions that are compatible with the old Xtend.
answered May 20, 2016 by mvut Veteran of the Digi Community (14,578 points)
OK, so I have a older 9XTEND module running firmware:  Product family: XTO9 Function set: 9xTEND 115K HOPPING (digiMesh)version 8064

and a new SX running Product Family: XBP9X, function set XBEE PRO SX, version 9003

Do I need to change one or the other to make them compatbile?  Because the way they're configured now, they can't talk to each other.
Yes the SX module needs to be running the XCT Digi Mesh function set and Code.
I changed the new 900SX to
XBP9XT-DM: XTC DigiMesh: 8003

and left the 9XTEND set to
XT09: XTEND 115K Hopping (Digimesh): 8064

Still no joy -- if someone could provide the details of compatible firmware on each side of the link, I'd appreciate it.
What if you change over to the Non Mesh versions of the Code? Are you then able to communicate?
...