Home/Support/Support Forum/Network security in transparent mode?

Network security in transparent mode?

0 votes
Hi,

I am using S2C modules in my project. I did several tests on the modules using XCTU software. I performed AT-AT throughput test with the modules and I got about 23kbps throughput. However, when I enabled the encryption features (NK, KY, EE, EO), the throughput test crashed and no packet is transmitted. What is the problem here? Is the security not being provided in transparent mode?


Thanks,

Gokhan
asked May 31, 2016 in ZigBee PRO Featureset (and legacy ZNet 2.5) by gcelik123 New to the Community (5 points)

Please log in or register to answer this question.

1 Answer

+1 vote
 
Best answer
For higher baud rate above 19200, use hardware flow control and your issue will get resolved.

For this, while adding module in XCTU, select Flow Type: "Hardware" instead of "None".
answered May 31, 2016 by asgm Veteran of the Digi Community (1,495 points)
selected Jun 1, 2016 by gcelik123
Thanks for your answer. I will try this. I used console terminal program to send data from coordinator to router and vice versa in AT-AT mode. When I enabled security, the throughput drammatically decreases from 31 kbps to 7 kbps. Should it  be like that? In addition, how can we achieve the practical throughput which are given in the product manual of XBee Pro ZB S2C as 58 kbps and  34 kbps when the security enabled and disabled, respectively?
...