Home/Support/Support Forum/Problem digital O/I with push button and led (Xbee s2 XB24-ZB)

Problem digital O/I with push button and led (Xbee s2 XB24-ZB)

0 votes
Hello,

I'm a french student and I'm working on two xbee modules serie 2 to light one led which is on a digital output of the first Xbee then a push button on a digital input Low of the other Xbee module.

I have tried to configure a v21A7 API module coordinator and the other peripheral module End AT v28A7 with the same ID and other parameters for the two to communicate. It's ok because when I connect the coordinator on my PC with Xbee usb explorer and that I read the frames sent by the end device, I observe well the change of data when I press the push button.

The problem is when I connect the coordinator on my breadboard and press the button, the LED doesn't light up.

If anyone has a solution, I'm very interested.

Thank you for your help.
asked Jun 2, 2016 in RF Solutions and XBee by vagoyon New to the Community (0 points)

Please log in or register to answer this question.

2 Answers

0 votes
The product you are using does not support what is called Digi IO line passing or GPIO. On this product you must issue Remote AT command to both read and change the values. That is to say, the Coordinator would need to be connected to a processor of some sort that can read the data from the button press and then send a remote AT command to trigger the line on the remote radio.
answered Jun 3, 2016 by mvut Veteran of the Digi Community (15,156 points)
Thank you for your answer and your help, I will try it.
0 votes
i have same problem ,can you pls tell more details to how to control led wirelessly,

pls i really want to learn as soon as possible pls tell me.
answered Sep 13, 2016 by baraiyanirav2225 New to the Community (4 points)
...