Home/Support/Support Forum/Transparent mode not working in one direction

Transparent mode not working in one direction

0 votes
I am trying to connect two Xbee S3B units together using transparent mode. The purpose is for purely direct serial comms. When I use them in explorer bases I can communicate using minicom across both units in either direction. Central gateway > pump unit pump unit> central gateway. I have set ATID- same, ATBD-3 both units, ATD6-0 ATD7-0 ATAP-0 if necessary I will post the minicom script I'm using to program them.
However when I take one unit out of the explorer base and put it into my arduino shield, or use a break out board with arduino It will no longer work when transmitting from gateway to pump unit but will work from pump unit to central gateway. I have configured the arduino to spit out the relay state and also a hello world on setup. I am finding this is getting through but any comms from the central gateway is not getting through. What is strange is that the base I have it attached to in the arduino is showing that it is associated. The gateway unit is showing association and that data is getting to it, whn I type the Data in light is coming on but nothing is being received at the other end. This is a little strange as when plugged back into explorer bases with no change to settings they instantly communicate. I'm suspecting a hardware issue, do I need to pull a pin to ground to enable the communications getting through? Is there something obvious that I am missing?
asked Jun 7, 2016 in RF Solutions and XBee by simonpearce New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
First off, the XBee is a 3V device and most Arduino boards are 5V so you do need to use an XBee Arduino shield.

Next, Most Arduino code for the XBee requires the radio to be in API mode 2 (at the Arduino).
answered Jun 7, 2016 by mvut Veteran of the Digi Community (11,320 points)
...