Home/Support/Support Forum/Can't update radio firmware, Can't detect modules. Ports "already in use"

Can't update radio firmware, Can't detect modules. Ports "already in use"

0 votes
I installed the correct drivers for my Sparkfun USB Xbee dongles and they show up as COM6 and COM7 in my device manager. When I try to detect or add the modules in XCTU, I get "Could not find any device in port COM6(and 7)> Error initializing Xbee device parameters> Port is already in use by other applications."

But I'm not running any other applications. I tried doing this in safe mode, but that didn't work at all.

In addition, any time I or the program try to update the radiofirmware library, it generates the error message "Error while downloading Firmware library: the server name or address (ftp1.digi.com) could not be resolved"

I'd point it to a file location if I could ever find where to get the file from, but that's nowhere to be found.

What direction should I move on this?
asked Jun 8, 2016 in XBee Programmable Development by Flieronymus New to the Community (2 points)

Please log in or register to answer this question.

1 Answer

0 votes
i think the problem with pc.if you not closed com port properly the problem may happen.

try to reinstall the drivers once again and see
answered Jun 11, 2016 by csreddy Seasoned Professional (195 points)
How would I close my com port? This is not something that one would normally be expected to do. I've installed the driver twice and it still doesn't work.