Home/Support/Support Forum/XBee 802.15.4 (Series 1) radio Not Going into Sleep Mode

XBee 802.15.4 (Series 1) radio Not Going into Sleep Mode

0 votes
I have an XBee 802.15.4 (Series 1) radio that I want to put into Sleep Mode periodically. SM is currently set to 1. When I pull pin 9 HI, I thought the XBee was in sleep mode, but am measuring about 26 mA of current draw idling. I'm showing about 87 mA when transmitting (and Pin #9 = LOW). I'd like to be seeing just a few microamps drawn when in Sleep Mode (Pin 9 = HIGH). What am I doing wrong?
Thanks,
Tim
asked Jun 26, 2016 in IEEE 802.15.4 by TimWilson New to the Community (2 points)

Please log in or register to answer this question.

2 Answers

0 votes
if I recall you need to set all unused DIO lines to output low and leave them floating. You then need to disable all unused pull up resistors except for DI to off.
answered Jun 27, 2016 by mvut Veteran of the Digi Community (11,302 points)
0 votes
Thank you for your reply. When I saw your reply I thought, "Yes!, that makes perfect sense!" So I confirmed all unused outputs were low and disabled all unused pull-ups, tried it again and no change in power consumption. Using an LED on the SLEEP indicator on Pin #13 and the AI indicator on Pin #15, I can see that it is put into SLEEP mode when Pin #9 goes HIGH, but the power consumption does not reduce down. It just idles about 26 mA. Can't imagine it being bad, So I suppose the next step is to do a factory reset and reprogram it. Any other comments would be helpful for something that should be trivial.
Thanks,
Tim
answered Jun 30, 2016 by TimWilson New to the Community (2 points)
...