Home/Support/Support Forum/2 Xbees will talk to each other, but API will not talk to Arduino...

2 Xbees will talk to each other, but API will not talk to Arduino...

0 votes
I ordered 3 identical Series 2 Zigbees. Months ago I easily got 2 of them talking together, as shown by Adafruit's great little backpack with the red/green status LEDs. I then simply hooked the API's RX->TX and TX->RX on a Mega and read all the serial data being transmitted from the AT to the API. The AT burnt out, I replaced it with one configured exactly the same in XCTU, they talk to each other like normal (red LED goes on) but I cannot seem to get any data to the Arduino serial terminal! Help!

Worth noting, the API xbee no longer is recognized directly by XCTU. I can only configure it by switching my Router AT to a router API, then "detecting other units in the same network". So why can I only configure the API remotely? Why does the software not recognize it directly? It says "no bootloaders found" when I try Recovery on the API. Range test works great, shows packages sent/received between the two. Did I somehow fry the API's serial capability while leaving everything else intact? Please help!

UPDATE:
I've tried everything i can think of to get this API talking, including swapping it to a router AT (via remote programming through the brand new, functioning, Router AT-turned-Coordinator-API...). So I essentially swapped the two Xbees' networking roles and STILL the same physical Xbee is unreachable directly. I'm at a loss on how everything but serial comm can function in a unit.
asked Jul 27, 2016 in IEEE 802.15.4 by dgriggs New to the Community (0 points)
edited Jul 26, 2016 by dgriggs

Please log in or register to answer this question.

1 Answer

0 votes
Are you connecting the 3V XBee ZB module direct to a 5V Arduino or a PC? From the sounds of it you are. Which would explain why you are no longer able to communicate with them as they have been burned up. You see the XBee is a 3V Device which is NOT 5V tolerant. In order to connect the 3V XBee to a 5V device, a level shifter such as an XBee Shield is required.
answered Jul 28, 2016 by mvut Veteran of the Digi Community (12,309 points)
Forgot to mention, I am using a Seeed Xbee shield, and an Xbee adapter from Adafruit, both of which regulate the Arduino 5V down to a voltage appropriate for the Xbee. Thanks for responding though!
What is the exact part number of the XBee modules you are having issue with and what firmware version is installed?
XB24-Z7WIT-004 revK 0013A20040FC8737 is one each one's plate. Also above that is 201WW07215215, all the same.

Oh and firmware is 21A7 for the Coordinator API, 22A7 for the Router AT.
Most of the sample code that you find on the web have the XBee modules both in API mode. What I would suggest is removing the radio for a few min and just connect the Arduino to a PC.  Then look at the API frame coming out the UART and what should be going into the radio.  Check it with XCTU to see if it is a valid frame and what kind of frame it is.
...