Home/Support/Support Forum/DHCP - device has max mask length of /24, can this be changed?
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

DHCP - device has max mask length of /24, can this be changed?

0 votes
The network I need to connect to is issuing a /19 IP to my ethernet WAN interface which is set to DHCP. The issue is the device seems to have a default max mask length of /24 so the next hop is seen as been in a different subnet to the issued IP.

Pretty sure it can be over-ridden just don't know the CLI command to do so.

Thanks.
asked Aug 10, 2016 in Digi TransPort Cellular by bdr848 New to the Community (0 points)

Please log in or register to answer this question.

2 Answers

0 votes
Hi

when the wan interface was setup for dhcp client

you have to make sure the interface mask is cleared.

or try setting it with the /19 mask

regards
answered Aug 11, 2016 by James.Wilson Veteran of the Digi Community (1,227 points)
That doesn't work, setting it for /19 is one way of course, but is bad practice, the device should use the mask sent in the DHCP response, it doesn't, it ignores it and uses /24. There is a CLI command to override it, I just can't find it.
0 votes
I guess it depends on which interface/port you are connecting to. For example, if you are connected to LAN 0, do

eth 0 mask "255.255.224.0"
answered Aug 11, 2016 by bzee New to the Community (4 points)
Hi

if you are using ETH 0 you should make sure the mask is clear first and see if it picks up the mask correctly.

eth 0 mask ""

if that does not work i would check to make sure you are getting the correct mask from the server by traceing the DHCP packets and see what is being passed.

regards

James
it should be picked up dynamically by the interface from the DHCP response, that is is the issue, setting it statically defeats the object.
...