Home/Support/Support Forum/Can not connect Philips HUE bulb by XB24-Z7WIT-004
New and improved user forum site going live on 12/6 (All users will need to reset their password when the new forum is active)

Can not connect Philips HUE bulb by XB24-Z7WIT-004

0 votes
I am trying to build up ZigBee network by XB24-Z7WIT-004 and let Philips Hue bulb join it.
However when I tried in XCTU tool to scan the network. It can not find the Hue bulb.
Here is my setting.
The XBee module firmware is ZigBee Coordinator API.
Port 9600/8/N/1N API 1

I also tried to change the baud rate and still no luck.

Does anyone has experience to conncet Hue bulb?
asked Aug 17, 2016 in DigiMesh Proprietary Mesh Networking by lijohnny1026 New to the Community (0 points)

Please log in or register to answer this question.

2 Answers

0 votes
Is there anything online that makes you think this would work in the first place (genuinely curious)?

As far as I am aware you cannot use this module to talk to this device. You would need a S2C module which can talk ZigBee HA protocol and then use a separate controller to send the Light Link messages.

answered Aug 18, 2016 by NicholasWilson Veteran of the Digi Community (1,003 points)
You are correct. You would need to use the S2C with the ZB or Zigbee firmware installed in order to do it as the S2B does not support the HA protocol for which the device in question does.
Actually, I just tried to reproduce the ZigBee adapter sample from Microsoft.

That's the module used in this article.
I replace it with new S2C module.
Now I can see the Philips Hue bulb, however when I try to click on it, it always shows could not initialize remote device.
Anyone can help?
What do you mean by "Click on the device"? Can you be more specific? For example, in what application are you clicking on the device in?
Hi Mvut,

I use the XCTU tool and tried to create a Zigbee network by use S2C module as cooridator role.
And then I clicked the scan button to scan the network. In the screen, I could see the S2C module find the philips Hue bulb with a gray line. However the line between them is something like 255/?.
When I click the icon for Hue. It asked me to initial this device. That's the time I got could not initialize remote device error.
It looked like the S2C module can find the Zigbee device, but can not communicate with Philips Hue.
Have you changed the ZS parameter on the S2C to Zigbee PRO?

Have you look into the Light Link profile to see what other settings may be required like encryption?
Hi Mvut,

Thansk for your promptly reply.
Yes, I tried them before. I changed the ZS=2 (Zigbee Pro) and EE encryption =1(enable).
But still no luck...
Do you know any other things I might be missing ?
I think you are going to need to check with the person who wrote the article you are working with to find out why it is not working.
Hi Mvut,

Thanks for your suggestion. I already asked this question in Microsoft community as well.
By the way, I copy the profile configuration of the XBee XB24C as below. Could you help to check if anything I can change to help connect Philips Hue Bulb? Thanks again. I
<?xml version="1.0" encoding="UTF-8"?>

      <setting command="ID">1D</setting>
      <setting command="SC">7FFF</setting>
      <setting command="SD">3</setting>
      <setting command="ZS">2</setting>
      <setting command="NJ">FF</setting>
      <setting command="NW">0</setting>
      <setting command="JV">0</setting>
      <setting command="JN">0</setting>
      <setting command="CE">1</setting>
      <setting command="DO">0</setting>
      <setting command="DC">0</setting>
      <setting command="DH">0</setting>
      <setting command="DL">FFFF</setting>
      <setting command="NI">Bridge</setting>
      <setting command="NH">1E</setting>
      <setting command="BH">0</setting>
      <setting command="AR">FF</setting>
      <setting command="DD">A0000</setting>
      <setting command="NT">3C</setting>
      <setting command="NO">0</setting>
      <setting command="CR">3</setting>
      <setting command="SE">E8</setting>
      <setting command="DE">E8</setting>
      <setting command="CI">11</setting>
      <setting command="TO">0</setting>
      <setting command="PL">4</setting>
      <setting command="PM">1</setting>
      <setting command="EE">1</setting>
      <setting command="EO">0</setting>
      <setting command="KY"></setting>
      <setting command="NK"></setting>
      <setting command="BD">3</setting>
      <setting command="NB">0</setting>
      <setting command="SB">0</setting>
      <setting command="RO">3</setting>
      <setting command="D7">1</setting>
      <setting command="D6">0</setting>
      <setting command="AP">1</setting>
      <setting command="AO">7</setting>
      <setting command="CT">64</setting>
      <setting command="GT">3E8</setting>
      <setting command="CC">2B</setting>
      <setting command="SP">20</setting>
      <setting command="SN">1</setting>
      <setting command="SM">0</setting>
      <setting command="ST">1388</setting>
      <setting command="SO">0</setting>
      <setting command="WH">0</setting>
      <setting command="PO">0</setting>
      <setting command="D0">1</setting>
      <setting command="D1">0</setting>
      <setting command="D2">0</setting>
      <setting command="D3">0</setting>
      <setting command="D4">0</setting>
      <setting command="D5">1</setting>
      <setting command="D8">1</setting>
      <setting command="D9">1</setting>
      <setting command="P0">1</setting>
      <setting command="P1">0</setting>
      <setting command="P2">0</setting>
      <setting command="P3">1</setting>
      <setting command="P4">1</setting>
      <setting command="PR">1FBF</setting>
      <setting command="PD">1FFF</setting>
      <setting command="LT">0</setting>
      <setting command="RP">28</setting>
      <setting command="IR">0</setting>
      <setting command="IC">0</setting>
      <setting command="V+">0</setting>
Looks like your EO setting is incorrect. It should be set to a value of 2.  AO should also be a value of 2 and KY 0x5A6967426565416C6C69616E63653039

This is all from http://knowledge.digi.com/articles/Knowledge_Base_Article/Zigbee-Home-Automation/?q=Home+Automation&l=en_US&fs=Search&pn=1
Hi Mvut,

I changed the configuration and make it the same with the link of KB you provided. Still, no luck.

By the way, besides Home Automation, how about configure Xbee to connect by Zigbee light link profile? Is it possible? What's the correct configuration for ZigBee light link profile?

I have not tried the Light Link profile so I do not know if the steps that Microsoft are valid or not.  I do know that the steps in the KB article for Home Automation are correct.
0 votes

Have a look at this and change few parameters. Many got that combination working.
answered Jul 9, 2018 by Chandra Dheeraj New to the Community (1 point)