Home/Support/Support Forum/XBEE PRO worked for two years, but has now UART errors

XBEE PRO worked for two years, but has now UART errors

0 votes
My XBEE worked fine and has been in the field for two years, but now the communication is intermittent at best. For simple operations like reading the serial number through ATSH and ATSL, they sometimes work, but there are often errors like a '"' instead of a '3' (they are one bit off in ASCII code) or sometime it is complete garbage (Z<ÇRLM n !). Trying enough times will eventually cause the command to go through, but it is extremely flaky. Sometimes the XBEE doesn't respond at all when testing the "+++" command. Monitoring the RX/TX pins on the oscilloscope showed that the '+' made it to the XBEE, but there was no respond back to the microcontroller. Replacing the XBEE restored all communications. Did I just get a bad XBEE? Is this common? Is there a work around?
asked Aug 19, 2016 in RF Solutions and XBee by Nick Morley New to the Community (0 points)

Please log in or register to answer this question.

2 Answers

0 votes
What exactly is the XBee module mounted to? Is it connected direct to a micro processor? If so, what voltage level is that processor running at? What is the part number of the xbee module you are working with?
answered Aug 19, 2016 by mvut Veteran of the Digi Community (11,300 points)
It is connected directly to a PIC32MX (logic levels/VDD = 3.3V). I'm using a pair of XBP9B-DMWT-002
Try forcing a new copy of the firmware onto the radio using XCTU.
I opened the XBEE in XCTU, but it wouldn't let me update the firmware (unable to reset device). Comparing the config and firmware to my working XBEE, I saw that the only difference in the config was the good one had DH = 1 and PD = 7f7f while the bad one had DH = 0 and PD = 7FFF. Changing those values on the bad XBEE to match the good XBEE locked me out of the device. I can't get a response over AT commands and XCTU fails to connect
Try communicating over the air with the API function and remote AT commands.  If that does not work, time to replace it.
How do I enable the API function to connect remotely?
That depends on which XBee module you are working with.  Some versions you have to change the firmware on a node to the API version (S2 and S2B), others it is nothing more than enabling the ATAP command to a value of 1. Then properly formatting and sending the API frame.
I couldn't get the XBEE to respond to any more AT commands so I used XCTU to recover the firmware and it fixed the issue. Thanks for your help!
0 votes
What firmware were you using? I have had similar problems with products in the field for 2 years (10ec firmware) and all the sudden I am having connection issues on sites with high wifi and audio streaming traffic.

Let me know what you found.
answered Oct 13, 2016 by ChetManly New to the Community (1 point)
...