Home/Support/Support Forum/Arduino+XBEE+ConnectPort data via Arduino's Serial class

Arduino+XBEE+ConnectPort data via Arduino's Serial class

0 votes
Hello friends, I am trying to send data from my xbee end device module on an xbee shield using Arduino's serial.write() to my ConnectPortx4 without success... i am using this script to send the data to Device Cloud http://www.digi.com/wiki/developer/index.php/XBee_to_Device_Cloud_-_DataPoint_Creation without error. but no data is beeing received on endpoint 0xE8? why is that so? how can i send serial data from the arduino+xbee to the connectport and then to DeviceCloud, thanks.
asked Sep 11, 2016 in Device Cloud-enabled RF Gateways by MateusPimentel New to the Community (0 points)

Please log in or register to answer this question.

2 Answers

0 votes
which XBee modules and connect port are you working with?
answered Sep 12, 2016 by mvut Veteran of the Digi Community (11,300 points)
xbee S2 Pro ZB and a ConnectPort X4 ZB thank you
For that to work, you need to write and port an application to the gateway that accepts the data from the XBee and sends it to the cloud.
0 votes
You can enabled low-level tracing on the X4 for debug purposes. Telnet to its IP address and enter the following command.

> set trace state=on mask=mesh:*

This will start dumping all serial traffic to/from the XBee (i.e. mesh) including the RX API frames you are expecting from the remote XBee. Those frames should be API ID 0x91 which you can look up in the XBee manual for help decoding the frames.

If you can see the expected data in the trace then the issue may be in the provided sample. If data isn't in the trace then looking at some sort of configuration failure. XBee may not be joined to the gateway's network, not in transparent serial mode, etc.

Either way this will hopefully help you get a little closer to the problem.
answered Sep 15, 2016 by jlovinger Veteran of the Digi Community (421 points)
...