Home/Support/Support Forum/Frequent connect/disconnect on WR41
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Frequent connect/disconnect on WR41

0 votes
Hi

I have a number of WR41s that’s been running fine for several years.

A couple of weeks ago one router failed to connect.
I’ve now found time to take a look at it but I’m unable to find the reason or solving the problem.

The router seams to connect/disconnect frequently.
-I’ve tried version 5235 and 5246 using flashwriter method and it’s the same result.
-I replaced the SIM-card with a new one just to be sure but that didn’t help either.
-I've tried antother subscription (new number) but it made no difference.
-I’ve tried the router on two sites 50km apart to exclude anything “tower related” but no change.

From the logfile I can see the signal isn’t strong but not to bad although it seems to vary quiet a lot for a route in the same spot. I have another WR41 and one HR4420 on my desk and those are working fine.

Network status also wari alot (se below)

Anyone else that experience this or has any clues?

//Johan


Outcome: Got modem status OK:
Time: 24 Oct 2016 10:12:49
SIM status: SIM PIN
Signal strength: -89 dBm
Manufacturer: Option N.V.
Model: GTM380
IMEI: 357564013694512
IMSI: ERROR: operation not allowed
ICCID: 89460120160722599906
Firmware: 2.9.1Hd (Date: Dec 17 2007, Time: 16:00:17)
GPRS Attachment Status: Not attached
GPRS Registration: Not registered, not searching
GSM Registration: Not registered, not searching
Network: 0,0,"Limited Service",2
Preferred system: WCDMA first
GSM Cell mode: Unknown
WCDMA Cell mode: WCDMA+HSDPA+HSUPA
Last Error Report: No cause information available
OK

Registration Status: Registered, home network
Signal Strength: Signal StrengthSignal StrengthSignal Strength (-75 dBm)
Mobile Statistics
IP Address: 90.235.68.104
Primary DNS Address: 195.67.199.18
Secondary DNS Address: 195.67.199.19
Data Received: 60.41 MB
Data Sent: 33.43 MB
Mobile Information
Results of Last Module Status Poll at 25 Oct 2016 08:17:33
Outcome: Got modem status OK
SIM status: READY
Signal strength: -75 dBm
Manufacturer: Option N.V.
Model: GTM380
IMEI: 357564013694512
IMSI: 240016026443609
ICCID: 89460120160722599906
Firmware: 2.9.1Hd (Date: Dec 17 2007, Time: 16:00:17)
GPRS Attachment Status: Attached
GPRS Registration: Registered, home network
GSM Registration: Registered, home network lac:3F7 ci:A084
Network: 0,0,"Telia",0
Preferred system: WCDMA first
GSM Cell mode: EDGE
WCDMA Cell mode: Non WCDMA/not registered
Last Error Report: No cause information available

20:40:42, 25 Oct 2016,Default Route 0 Out Of Service,Activation
20:40:42, 25 Oct 2016,PPP 1 Out Of Service,Activation
20:40:42, 25 Oct 2016,GPRS Registration Off
20:40:42, 25 Oct 2016,GPRS Attachment Off
20:40:32, 25 Oct 2016,Network technology changed to UMTS/HSDPA
20:39:55, 25 Oct 2016,GPRS Signal Strength: -79 dBm, "Telia" EDGE ci:B5A6 SIM 1 (present)
20:39:55, 25 Oct 2016,Event delay,Logger busy
20:39:42, 25 Oct 2016,WEB Login OK by username lvl 0
20:38:55, 25 Oct 2016,GPRS Signal Strength: -79 dBm, "Telia" EDGE ci:B5A6 SIM 1 (present)
20:38:14, 25 Oct 2016,ETH 2 up
20:38:14, 25 Oct 2016,ETH 1 up
20:38:14, 25 Oct 2016,ETH 0 up
20:38:12, 25 Oct 2016,GSM Registration On
20:38:12, 25 Oct 2016,Default Route 0 Available,Activation
20:38:12, 25 Oct 2016,PPP 1 Available,Activation
20:38:12, 25 Oct 2016,GPRS Registration On
20:38:12, 25 Oct 2016,GPRS Attachment On
20:38:01, 25 Oct 2016,Network technology changed to GPRS/EDGE
20:37:55, 25 Oct 2016,GPRS Signal Strength: -113 dBm, WCDMA only ci:0000 SIM 1 (present)
20:37:36, 25 Oct 2016,GSM Registration Off
20:37:22, 25 Oct 2016,Default Route 0 Out Of Service,Activation
20:37:22, 25 Oct 2016,PPP 1 Out Of Service,Activation
20:37:22, 25 Oct 2016,GPRS Registration Off
20:37:22, 25 Oct 2016,GPRS Attachment Off
20:37:12, 25 Oct 2016,Network technology changed to UMTS/HSDPA
20:36:55, 25 Oct 2016,GPRS Signal Strength: -73 dBm, "Telia" EDGE ci:A492 SIM 1 (present)
20:36:52, 25 Oct 2016,GSM Registration On
20:36:52, 25 Oct 2016,Default Route 0 Available,Activation
20:36:52, 25 Oct 2016,PPP 1 Available,Activation
20:36:52, 25 Oct 2016,GPRS Registration On
20:36:52, 25 Oct 2016,GPRS Attachment On
20:36:44, 25 Oct 2016,Network technology changed to GPRS/EDGE
20:36:16, 25 Oct 2016,GSM Registration Off
20:36:02, 25 Oct 2016,Default Route 0 Out Of Service,Activation
20:36:02, 25 Oct 2016,PPP 1 Out Of Service,Activation
20:36:02, 25 Oct 2016,GPRS Registration Off
20:36:02, 25 Oct 2016,GPRS Attachment Off
20:35:55, 25 Oct 2016,GPRS Signal Strength: -93 dBm, "Telia" WCDMA+HSDPA ci:623F SIM 1 (present)
20:35:52, 25 Oct 2016,Network technology changed to UMTS/HSDPA
20:35:32, 25 Oct 2016,GSM Registration On
20:35:32, 25 Oct 2016,Default Route 0 Available,Activation
20:35:32, 25 Oct 2016,PPP 1 Available,Activation
20:35:32, 25 Oct 2016,GPRS Registration On
20:35:32, 25 Oct 2016,GPRS Attachment On
20:35:30, 25 Oct 2016,Network technology changed to GPRS/EDGE
20:35:15, 25 Oct 2016,GSM Registration Off
20:35:02, 25 Oct 2016,Default Route 0 Out Of Service,Activation
20:35:02, 25 Oct 2016,PPP 1 Out Of Service,Activation
20:35:02, 25 Oct 2016,GPRS Registration Off
20:35:02, 25 Oct 2016,GPRS Attachment Off
20:34:55, 25 Oct 2016,GPRS Signal Strength: -93 dBm, "Telia" WCDMA+HSDPA ci:623F SIM 1 (present)
20:34:52, 25 Oct 2016,Network technology changed to UMTS/HSDPA
20:34:32, 25 Oct 2016,GSM Registration On
20:34:32, 25 Oct 2016,Default Route 0 Available,Activation
20:34:32, 25 Oct 2016,PPP 1 Available,Activation
20:34:32, 25 Oct 2016,GPRS Registration On
20:34:32, 25 Oct 2016,GPRS Attachment On
20:34:24, 25 Oct 2016,Network technology changed to GPRS/EDGE
asked Oct 26, 2016 in Digi TransPort Cellular by JohanF New to the Community (10 points)

Please log in or register to answer this question.

2 Answers

0 votes
Your disconnects are happening exactly 30 seconds after bringing up a connection. I suspect it is either a configuration issue or your carrier is disconnecting your session due to no data. Many carriers are implementing this to save on RF bandwidth but normally they just degrade you.

Run a ping every two seconds and see if that "fixes it".

Check to make sure you dont have any rxtimeout setup or the like as well.
answered Oct 26, 2016 by NicholasWilson Veteran of the Digi Community (969 points)
0 votes
Tried another carrier that's not sharing any infrastructre but issue remains.

Not sure where to look for the rxtimeout?

Below is my "running" config wich is default apart from
apn,ping and "modemcc 0 check_reg 0"

Can it be HW related?

//Johan


config c show

eth 0 IPaddr "192.168.1.1"
addp 0 enable ON
lapb 0 ans OFF
lapb 0 tinact 120
lapb 1 tinact 120
lapb 3 dtemode 0
lapb 4 dtemode 0
lapb 5 dtemode 0
lapb 6 dtemode 0
ip 0 cidr ON
def_route 0 ll_ent "ppp"
def_route 0 ll_add 1
dhcp 0 IPmin "192.168.1.100"
dhcp 0 respdelms 500
dhcp 0 mask "255.255.255.0"
dhcp 0 gateway "192.168.1.1"
dhcp 0 DNS "192.168.1.1"
sntp 0 server "time.etherios.com"
ppp 0 timeout 300
ppp 1 name "W-WAN (HSPA 3G)"
ppp 1 phonenum "*98*1#"
ppp 1 IPaddr "0.0.0.0"
ppp 1 timeout 0
ppp 1 use_modem 1
ppp 1 aodion 1
ppp 1 autoassert 1
ppp 1 pingip "8.8.8.8"
ppp 1 pingint 3
ppp 1 ipanon ON
ppp 1 r_chap OFF
ppp 3 defpak 16
ppp 4 defpak 16
modemcc 0 info_asy_add 7
modemcc 0 init_str "+CGQREQ=1"
modemcc 0 init_str1 "+CGQMIN=1"
modemcc 0 apn "online.telia.se"
modemcc 0 link_retries 10
modemcc 0 stat_retries 30
modemcc 0 check_reg 0
modemcc 0 ss_interval 1
modemcc 0 sms_interval 1
modemcc 0 sms_access 1
modemcc 0 sms_concat 0
modemcc 0 init_str_2 "+CGQREQ=1"
modemcc 0 init_str1_2 "+CGQMIN=1"
modemcc 0 apn_2 "Your.APN.goes.here"
modemcc 0 link_retries_2 10
modemcc 0 stat_retries_2 30
ana 0 anon ON
ana 0 l1on ON
ana 0 lapdon 0
ana 0 asyon 1
ana 0 logsize 45
cmd 0 unitid "ss%s>"
cmd 0 cmdnua "99"
cmd 0 hostname "digi.router"
cmd 0 asyled_mode 2
cmd 0 tremto 1200
cmd 0 rcihttp ON
user 0 access 0
user 1 name "username"
user 1 epassword "KD5lSVJDVVg="
user 1 access 0
user 2 access 0
user 3 access 0
user 4 access 0
user 5 access 0
user 6 access 0
user 7 access 0
user 8 access 0
user 9 access 0
local 0 transaccess 2
sslsvr 0 certfile "cert01.pem"
sslsvr 0 keyfile "privrsa.pem"
ssh 0 hostkey1 "privSSH.pem"
ssh 0 nb_listen 5
ssh 0 v1 OFF
cloud 0 ssl ON

Power Up Profile: 0
OK
answered Oct 31, 2016 by JohanF New to the Community (10 points)
...